<!doctype html><html lang="en-US"><head><meta charset="UTF-8"><meta property="fb:pages" content="12622425949" /><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="http://esctoday.com/xmlrpc.php"><meta name="google-site-verification" content="v84ZTceatGXkFX9kMkQ792qROrAtxYOvO54Q-ixaV6A" /><link rel="apple-touch-icon" sizes="180x180" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/favicon-16x16.png"><link rel="manifest" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/site.webmanifest"><link rel="mask-icon" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/safari-pinned-tab.svg" color="#da532c"><link rel="shortcut icon" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/favicon.ico"><meta name="msapplication-TileColor" content="#da532c"><meta name="msapplication-config" content="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/browserconfig.xml"><meta name="theme-color" content="#ffffff"><title>Eurovision Cyprus: It&#039;s Elena Tsagrinou to Rotterdam! - ESCToday.com</title> <script>
if ( typeof WebFontConfig === "undefined" ) {WebFontConfig = new Object();}WebFontConfig['google'] = {families: ['Roboto:100,300,400,500,700,900,100italic,300italic,400italic,500italic,700italic,900italic', 'Exo+2:100,200,300,400,500,600,700,800,900,100italic,200italic,300italic,400italic,500italic,600italic,700italic,800italic,900italic&amp;subset=latin-ext']};(function() {var wf = document.createElement( 'script' );wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
wf.type = 'text/javascript';wf.async = 'true';var s = document.getElementsByTagName( 'script' )[0];s.parentNode.insertBefore( wf, s );})();</script> <meta name="description" content="Eurovision news: The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It&#039;s the"/><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="http://esctoday.com/181176/cyprus-its-elena-tsagrinou-to-rotterdam/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Eurovision Cyprus: It&#039;s Elena Tsagrinou to Rotterdam! - ESCToday.com" /><meta property="og:description" content="Eurovision news: The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It&#039;s the" /><meta property="og:url" content="http://esctoday.com/181176/cyprus-its-elena-tsagrinou-to-rotterdam/" /><meta property="og:site_name" content="Eurovision News, Polls and Information by ESCToday" /><meta property="article:publisher" content="http://facebook.com/esctoday" /><meta property="article:author" content="https://www.facebook.com/stratos.agadellis" /><meta property="article:tag" content="CyBC" /><meta property="article:tag" content="cyprus" /><meta property="article:tag" content="Elena Tsagrinou" /><meta property="article:tag" content="Eurovision 2021" /><meta property="article:tag" content="featured" /><meta property="article:tag" content="Internal selection" /><meta property="article:tag" content="Sandro Nicolas" /><meta property="article:section" content="Cyprus" /><meta property="article:published_time" content="2020-11-25T07:59:02+00:00" /><meta property="article:modified_time" content="2020-11-25T08:09:22+00:00" /><meta property="og:updated_time" content="2020-11-25T08:09:22+00:00" /><meta property="fb:app_id" content="1800027680295693" /><meta property="og:image" content="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-127254231_383104802956870_504435641260799847_n-1024x1024.jpg?x52282" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="1024" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Eurovision news: The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It&#039;s the" /><meta name="twitter:title" content="Eurovision Cyprus: It&#039;s Elena Tsagrinou to Rotterdam! - ESCToday.com" /><meta name="twitter:site" content="@esctoday" /><meta name="twitter:image" content="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-127254231_383104802956870_504435641260799847_n.jpg?x52282" /><meta name="twitter:creator" content="@esctoday" /><script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://esctoday.com/#website","url":"http://esctoday.com/","name":"Eurovision News, Polls and Information by ESCToday","potentialAction":{"@type":"SearchAction","target":"http://esctoday.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://esctoday.com/181176/cyprus-its-elena-tsagrinou-to-rotterdam/#primaryimage","url":"http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-127254231_383104802956870_504435641260799847_n.jpg?x52282","width":2048,"height":2048},{"@type":"WebPage","@id":"http://esctoday.com/181176/cyprus-its-elena-tsagrinou-to-rotterdam/#webpage","url":"http://esctoday.com/181176/cyprus-its-elena-tsagrinou-to-rotterdam/","inLanguage":"en-US","name":"Eurovision Cyprus: It&#039;s Elena Tsagrinou to Rotterdam! - ESCToday.com","isPartOf":{"@id":"http://esctoday.com/#website"},"primaryImageOfPage":{"@id":"http://esctoday.com/181176/cyprus-its-elena-tsagrinou-to-rotterdam/#primaryimage"},"datePublished":"2020-11-25T07:59:02+00:00","dateModified":"2020-11-25T08:09:22+00:00","author":{"@id":"http://esctoday.com/#/schema/person/ec6bbb527e1ab7dd6891673592c17244"},"description":"Eurovision news: The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It's the"},{"@type":["Person"],"@id":"http://esctoday.com/#/schema/person/ec6bbb527e1ab7dd6891673592c17244","name":"Stratos Agadellis","description":"Chemist. Restless spirit. Book and food lover. Eurovision passionate since childhood.","sameAs":["https://www.facebook.com/stratos.agadellis","https://www.instagram.com/stratosag/"]}]}</script><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Eurovision News, Polls and Information by ESCToday &raquo; Feed" href="http://esctoday.com/feed/" /><link rel='stylesheet' id='contact-form-7-css' href='http://esctoday.com/wp-content/plugins/contact-form-7/includes/css/styles.css?x52282' type='text/css' media='all' /><link rel='stylesheet' id='cookie-notice-front-css' href='http://esctoday.com/wp-content/plugins/cookie-notice/css/front.min.css?x52282' type='text/css' media='all' /><link rel='stylesheet' id='wpt-twitter-feed-css' href='http://esctoday.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?x52282' type='text/css' media='all' /><link rel='stylesheet' id='twitter-bootstrap-css' href='http://esctoday.com/wp-content/themes/esctoday/css/plugins/bootstrap/css/bootstrap.min.css?x52282' type='text/css' media='all' /><link rel='stylesheet' id='roboto-css' href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C500%2C700%2C900&#038;subset=cyrillic%2Cgreek' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css' href='http://esctoday.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?x52282' type='text/css' media='all' /><link rel='stylesheet' id='flag-icons-css' href='http://esctoday.com/wp-content/themes/esctoday/css/flags/flags.css?x52282' type='text/css' media='all' /><link rel='stylesheet' id='dt-style-css' href='http://esctoday.com/wp-content/themes/esctoday/style.css?x52282' type='text/css' media='all' /><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(http://esctoday.com/wp-content/plugins/rocket-lazy-load/assets/img/youtube.png) no-repeat;cursor:pointer}</style><script type='text/javascript' src='http://esctoday.com/wp-includes/js/jquery/jquery.js?x52282'></script><script type='text/javascript' src='http://esctoday.com/wp-includes/js/jquery/jquery-migrate.min.js?x52282'></script><script type='text/javascript'>
var cnArgs = {"ajaxUrl":"http:\/\/esctoday.com\/wp-admin\/admin-ajax.php","nonce":"8b802dfc9f","hideEffect":"fade","position":"bottom","onScroll":"0","onScrollOffset":"100","onClick":"0","cookieName":"cookie_notice_accepted","cookieTime":"2592000","cookieTimeRejected":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"0","cache":"1","refuse":"0","revokeCookies":"0","revokeCookiesOpt":"automatic","secure":"0","coronabarActive":"0"};
</script><script type='text/javascript' src='http://esctoday.com/wp-content/plugins/cookie-notice/js/front.min.js?x52282'></script><script type='text/javascript' src='http://esctoday.com/wp-content/themes/esctoday/js/script.js?x52282'></script><link rel='https://api.w.org/' href='http://esctoday.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://esctoday.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://esctoday.com/wp-includes/wlwmanifest.xml" /> <meta name="generator" content="WordPress 4.9.16" /><link rel='shortlink' href='http://esctoday.com/?p=181176' /><link rel="alternate" type="application/json+oembed" href="http://esctoday.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fesctoday.com%2F181176%2Fcyprus-its-elena-tsagrinou-to-rotterdam%2F" /><link rel="alternate" type="text/xml+oembed" href="http://esctoday.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fesctoday.com%2F181176%2Fcyprus-its-elena-tsagrinou-to-rotterdam%2F&#038;format=xml" /><style type="text/css">.fve-video-wrapper{position:relative;overflow:hidden;height:0;background-color:transparent;padding-bottom:56.25%;margin:0.5em 0}.fve-video-wrapper iframe,.fve-video-wrapper object,.fve-video-wrapper embed{position:absolute;display:block;top:0;left:0;width:100%;height:100%}.fve-video-wrapper a.hyperlink-image{position:relative;display:none}.fve-video-wrapper a.hyperlink-image img{position:relative;z-index:2;width:100%}.fve-video-wrapper a.hyperlink-image .fve-play-button{position:absolute;left:35%;top:35%;right:35%;bottom:35%;z-index:3;background-color:rgba(40,40,40,0.75);background-size:100% 100%;border-radius:10px}.fve-video-wrapper a.hyperlink-image:hover .fve-play-button{background-color:rgba(0,0,0,0.85)}</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/><!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://esctoday.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?x52282" media="screen"><![endif]--> <script>window.OneSignal = window.OneSignal || [];OneSignal.push( function() {OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };OneSignal.setDefaultNotificationUrl("http://esctoday.com");
var oneSignal_options = {};window._oneSignalInitOptions = oneSignal_options;oneSignal_options['wordpress'] = true;oneSignal_options['appId'] = '848f6e44-da03-4e90-a389-be7fc0298ddb';oneSignal_options['welcomeNotification'] = { };oneSignal_options['welcomeNotification']['title'] = "";oneSignal_options['welcomeNotification']['message'] = "";oneSignal_options['subdomainName'] = "esctoday";oneSignal_options['safari_web_id'] = "web.onesignal.auto.147da6f8-95e8-4f3e-9e77-8dc52e1c58f0";oneSignal_options['persistNotification'] = false;oneSignal_options['promptOptions'] = { };OneSignal.init(window._oneSignalInitOptions);OneSignal.showSlidedownPrompt();      });function documentInitOneSignal() {var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);}if (document.readyState === 'complete') {documentInitOneSignal();}else {window.addEventListener("load", function(event){documentInitOneSignal();});}</script><script type="text/javascript">var ajaxurl = "http://esctoday.com/wp-admin/admin-ajax.php";var dt_path = "http://esctoday.com/wp-content/themes/esctoday";var dt_paginated_blocks = [];var dt_paginated_blocks_type = [];var dt_paginated_blocks_items = [];</script><noscript><style type="text/css"> .wpb_animate_when_almost_visible{opacity:1}</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none !important}</style></noscript><script async="async" src="//www.googletagservices.com/tag/js/gpt.js"></script><script>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];</script><script>googletag.cmd.push(function() {googletag.defineSlot('/6787190/esctoday2_336x280_1', [350, 250], 'div-gpt-ad-1510691866308-0').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_336x280_2', [300, 250], 'div-gpt-ad-1510691866308-1').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_728x90_top', [728, 90], 'div-gpt-ad-1510691866308-2').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_728x90_2', [728, 90], 'div-gpt-ad-1510691866308-3').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_article_mobile_1', [300, 250], 'div-gpt-ad-1510691866308-4').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_article_mobile_2', [300, 250], 'div-gpt-ad-1510691866308-5').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_970x250//90', [970, 250], 'div-gpt-ad-1510691866308-6').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();googletag.pubads().collapseEmptyDivs();googletag.enableServices();});</script><script>jQuery(function ($) {$(document).ready(function () {if(['iPad', 'iPhone', 'iPod'].indexOf(navigator.platform) >= 0) {$('body').addClass('isIos');} else {$('body').addClass('isNotIos');}});});</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-28910909-1', 'auto');ga('require', 'displayfeatures');ga('send', 'pageview');</script><style>.isIos .parallax-image-holder{background-attachment:scroll}.grecaptcha-badge{display:none !important}@media(min-width:768px){.countries-cols UL LI{display:inline-block;width:25%}.countries-cols UL{width:650px}}</style></head><body class="post-template-default single single-post postid-181176 single-format-standard cookies-not-set sticky-header big-header top-header wide wpb-js-composer js-comp-ver-5.6 vc_responsive"><div id="fb-root"></div><div id="main"><header class="header-wrapper clearfix"><div class="header-top"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-12"><div class="menu-top_menu-container"><ul id="secondary-menu" class="top-menu pull-left"><li id="menu-item-107194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107194"><a href="http://esctoday.com/eurovision-news/eurovision-news-sweden-2016/">News</a></li><li id="menu-item-108240" class="menu-item menu-item-type-post_type_archive menu-item-object-participant menu-item-108240"><a href="http://esctoday.com/participant/">Participants</a></li><li id="menu-item-130047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130047"><a href="http://esctoday.com/contact/">Contact Us</a></li><li id="menu-item-139654" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139654"><a href="http://esctoday.com/eurovision-calendar/">Calendar</a></li></ul></div><div class="social-icons pull-right"><a href="http://facebook.com/esctoday" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Facebook" target="_blank"><i class="fa fa-facebook fa-lg"></i></a><a href="http://twitter.com/esctoday" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Twitter" target="_blank"><i class="fa fa-twitter fa-lg"></i></a><a href="http://youtube.com/esctodaytv" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Youtube" target="_blank"><i class="fa fa-youtube fa-lg"></i></a><a href="https://www.linkedin.com/company/506308" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Linkedin" target="_blank"><i class="fa fa-linkedin fa-lg"></i></a><a href="https://www.instagram.com/esctoday" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Instagram" target="_blank"><i class="fa fa-instagram fa-lg"></i></a></div></div></div></div></div></div><div class="header-mid"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-12"><div class="header-mid-wrapper clearfix"><div class="mid-logo-wrapper"><a class="logo" href="http://esctoday.com/" title="Eurovision News, Polls and Information by ESCToday - Your daily Eurovision news centre" rel="home"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Eurovision News, Polls and Information by ESCToday" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-logo-20years.png?x52282"/><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-logo-20years.png?x52282" alt="Eurovision News, Polls and Information by ESCToday"/></noscript></a></div><div class="header-banner"><div id="div-gpt-ad-1510691866308-2" class="showDesktop"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-2'); });</script></div></div></div></div></div></div></div></div><div class="header" id="header"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-12"><a class="navbar-toggle collapsed" id="nav-button" href="#mobile-nav"><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span></a><nav class="navbar mega-menu"><a class="logo" href="http://esctoday.com/" title="Eurovision News, Polls and Information by ESCToday - Your daily Eurovision news centre" rel="home"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Eurovision News, Polls and Information by ESCToday" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-logo-20years-small.png?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-logo-20years-small.png?x52282" alt="Eurovision News, Polls and Information by ESCToday" /></noscript></a><div id="main-nav" class="collapse navbar-collapse"><ul id="menu-main-menu" class="nav navbar-nav"><li id="menu-item-38557" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-38557 dropdown menu-color10885"><a href="http://esctoday.com/eurovision-news/" class="dropdown-toggle" aria-haspopup="true">News <span class="caret"></span></a><ul role="menu" class="dropdown-menu"><li id="menu-item-38559" class="countries-cols menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-38559 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news-countries/">All the Countries</a><ul role="menu" class="dropdown-menu"><li id="menu-item-108268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108268"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-albania/">Albania</a></li><li id="menu-item-108269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108269"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-andorra/">Andorra</a></li><li id="menu-item-108270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108270"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-armenia/">Armenia</a></li><li id="menu-item-108271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108271"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-australia/">Australia</a></li><li id="menu-item-108272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108272"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-austria/">Austria</a></li><li id="menu-item-108273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108273"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-azerbaijan/">Azerbaijan</a></li><li id="menu-item-108274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108274"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-belarus/">Belarus</a></li><li id="menu-item-108275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108275"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-belgium/">Belgium</a></li><li id="menu-item-108276" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108276"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-bosnia-herzegovina/">Bosnia &#038; Herzegovina</a></li><li id="menu-item-108277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108277"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-bulgaria/">Bulgaria</a></li><li id="menu-item-108278" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108278"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-croatia/">Croatia</a></li><li id="menu-item-108279" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-108279"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-cyprus/">Cyprus</a></li><li id="menu-item-108280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108280"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-czech-republic/">Czech Republic</a></li><li id="menu-item-108281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108281"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-denmark/">Denmark</a></li><li id="menu-item-108282" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108282"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-estonia/">Estonia</a></li><li id="menu-item-108283" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108283"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-finland/">Finland</a></li><li id="menu-item-108284" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108284"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-france/">France</a></li><li id="menu-item-108286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108286"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-georgia/">Georgia</a></li><li id="menu-item-108287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108287"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-germany/">Germany</a></li><li id="menu-item-108288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108288"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-greece/">Greece</a></li><li id="menu-item-108289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108289"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-hungary/">Hungary</a></li><li id="menu-item-108290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108290"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-iceland/">Iceland</a></li><li id="menu-item-108291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108291"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-ireland/">Ireland</a></li><li id="menu-item-108292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108292"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-israel/">Israel</a></li><li id="menu-item-108293" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108293"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-italy/">Italy</a></li><li id="menu-item-108294" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108294"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-latvia/">Latvia</a></li><li id="menu-item-108295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108295"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-lebanon/">Lebanon</a></li><li id="menu-item-108296" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108296"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-liechtenstein/">Liechtenstein</a></li><li id="menu-item-108297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108297"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-lithuania/">Lithuania</a></li><li id="menu-item-108298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108298"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-luxembourg/">Luxembourg</a></li><li id="menu-item-108299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108299"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-malta/">Malta</a></li><li id="menu-item-108300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108300"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-moldova/">Moldova</a></li><li id="menu-item-108301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108301"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-monaco/">Monaco</a></li><li id="menu-item-108302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108302"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-montenegro/">Montenegro</a></li><li id="menu-item-108303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108303"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-morocco/">Morocco</a></li><li id="menu-item-108285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108285"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-north-macedonia/">North Macedonia</a></li><li id="menu-item-108304" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108304"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-norway/">Norway</a></li><li id="menu-item-108305" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108305"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-poland/">Poland</a></li><li id="menu-item-108306" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108306"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-portugal/">Portugal</a></li><li id="menu-item-108307" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108307"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-romania/">Romania</a></li><li id="menu-item-108308" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108308"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-russia/">Russia</a></li><li id="menu-item-108309" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108309"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-san-marino/">San Marino</a></li><li id="menu-item-108310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108310"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-serbia/">Serbia</a></li><li id="menu-item-108311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108311"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-serbia-montenegro/">Serbia &#038; Montenegro</a></li><li id="menu-item-108312" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108312"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-slovakia/">Slovakia</a></li><li id="menu-item-108313" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108313"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-slovenia/">Slovenia</a></li><li id="menu-item-108314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108314"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-spain/">Spain</a></li><li id="menu-item-108315" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108315"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-sweden/">Sweden</a></li><li id="menu-item-108316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108316"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-switzerland/">Switzerland</a></li><li id="menu-item-108317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108317"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-the-netherlands/">The Netherlands</a></li><li id="menu-item-108318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108318"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-turkey/">Turkey</a></li><li id="menu-item-108319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108319"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-ukraine/">Ukraine</a></li><li id="menu-item-108320" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108320"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-united-kingdom/">United Kingdom</a></li><li id="menu-item-108321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108321"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-yugoslavia/">Yugoslavia</a></li></ul></li><li id="menu-item-38561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38561"><a href="http://esctoday.com/eurovision-news/eurovision-news-past-participants/">News about Past Participants</a></li><li id="menu-item-38560" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38560"><a href="http://esctoday.com/eurovision-news-ogae/">News from Fan Clubs</a></li><li id="menu-item-38562" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38562"><a href="http://esctoday.com/eurovision-news-archive/">News Archive/History</a></li></ul></li><li id="menu-item-180984" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-180984 dropdown menu-color11301"><a href="http://esctoday.com/eurovision-news/the-netherlands-2021/" class="dropdown-toggle" aria-haspopup="true">Rotterdam 2021 <span class="caret"></span></a><ul role="menu" class="dropdown-menu"><li id="menu-item-180985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-180985"><a href="http://esctoday.com/participant?contest_year=2021">Participants</a></li></ul></li><li id="menu-item-137361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-137361 dropdown"><a href="#" class="dropdown-toggle" aria-haspopup="true">Previous Years <span class="caret"></span></a><ul role="menu" class="dropdown-menu"><li id="menu-item-177171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177171 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-the-netherlands-2020/">Rotterdam 2020</a><ul role="menu" class="dropdown-menu"><li id="menu-item-177172" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-177172"><a href="http://esctoday.com/participant?contest_year=2020">Participants</a></li></ul></li><li id="menu-item-171446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-171446 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-israel-2019/">Tel Aviv 2019</a><ul role="menu" class="dropdown-menu"><li id="menu-item-171447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171447"><a href="http://esctoday.com/participant?contest_year=2019">Participants</a></li></ul></li><li id="menu-item-148277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-148277 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-portugal-2018/">Portugal 2018</a><ul role="menu" class="dropdown-menu"><li id="menu-item-171445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171445"><a href="http://esctoday.com/participant?contest_year=2018">Participants</a></li><li id="menu-item-171444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171444"><a href="http://esctoday.com/eurovision-news-discover-lisbon/">Discover Lisbon</a></li></ul></li><li id="menu-item-137362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-137362 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-ukraine-2017/">Ukraine 2017</a><ul role="menu" class="dropdown-menu"><li id="menu-item-162531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-162531"><a href="http://esctoday.com/participant?contest_year=2017">Participants</a></li><li id="menu-item-162530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162530"><a href="http://esctoday.com/eurovision-news-discover-kyiv/">Discover Kyiv</a></li></ul></li><li id="menu-item-104297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-104297 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-sweden-2016/">Sweden 2016</a><ul role="menu" class="dropdown-menu"><li id="menu-item-137583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-137583"><a href="http://esctoday.com/participant?contest_year=2016">Participants</a></li><li id="menu-item-137584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137584"><a href="http://esctoday.com/eurovision-news-discover-stockholm/">Discover Stockholm</a></li></ul></li><li id="menu-item-108242" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-108242 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-austria-2015/">Austria 2015</a><ul role="menu" class="dropdown-menu"><li id="menu-item-108246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-108246 dropdown"><a href="#">Participants</a><ul role="menu" class="dropdown-menu"><li id="menu-item-108245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108245"><a href="http://esctoday.com/participants/eurovision-song-contest-2015-semi-final-1/">Eurovision Song Contest 2015 – Semi-final 1</a></li><li id="menu-item-108244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108244"><a href="http://esctoday.com/participants/eurovision-song-contest-2015-semi-final-2/">Eurovision Song Contest 2015 – Semi-final 2</a></li><li id="menu-item-108243" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108243"><a href="http://esctoday.com/eurovision-song-contest-2015-grand-final/">Eurovision Song Contest 2015 – Grand Final</a></li></ul></li><li id="menu-item-108247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108247"><a href="http://esctoday.com/eurovision-news-discover-vienna/">Discover Vienna</a></li><li id="menu-item-108248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108248"><a href="http://esctoday.com/eurovision-news-specials/eurovision-news-video-message/">Eurostar&#8217;s Video Messages</a></li></ul></li></ul></li><li id="menu-item-142157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142157"><a href="http://esctoday.com/contact/">Contact Us</a></li></ul></div><div class="header-right"><div class="social-icons"></div><a href="#" class="fixed-button navbar-toggle" id="fixed-button"><i></i><i></i><i></i><i></i></a></div><div id="sb-search" class="sb-search"><form action="http://esctoday.com/" method="get"><input class="sb-search-input" placeholder="Enter your search text..." type="text" value="" name="s" id="search"><input class="sb-search-submit" type="submit" value=""><input type="hidden" value="post" name="post_type" id="post_type" /><span class="sb-icon-search fa fa-search" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Search"></span></form></div></nav></div></div></div></div></div></header><div id="content" class="site-content"> <div class="parallax-header"><div class="parallax-wrapper"><div data-bg="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-127254231_383104802956870_504435641260799847_n-1550x720.jpg?x52282" class="parallax-image-holder rocket-lazyload" style=""></div><div class="container"><div class="mag-content parallax-box"><div class="row"><div class="col-md-12 parallax-box"><header class="post-header"><h1 class="post-title">Cyprus: It&#8217;s Elena Tsagrinou to Rotterdam!</h1><div class="cat-wrapper"><a href='http://esctoday.com/eurovision-news-countries/eurovision-news-cyprus/' class='dt_cat bgcolor38'>Cyprus</a></div><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/eagadellisyahoo-gr/"><b>Stratos Agadellis</b></a></span> <span class="article-date"><i class="fa fa-clock-o"></i> November 25, 2020 8:59 am</span><span><i class="fa fa-eye"></i> 16 views</span><a class="comments-count" href="#comments"><span class="fb-comments-count" data-href=""></span></a></p></header></div></div></div></div></div></div>  <div class="container main-wrapper"> <div class="mag-content clearfix"> <div class="row"> <div class="col-md-12"> <div class="content-top-wrapper"><div id="div-gpt-ad-1510691866308-6" class="showDesktop"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-6'); });</script></div></div></div></div></div> <div class="main-content mag-content clearfix"> <div class="row blog-content"> <div class="col-md-8 main-wp dt_content"> <div class="theiaStickySidebar"> <div class="row"><div class="col-md-12"><article id="post-181176" class="dt_post_content clearfix post-181176 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-cyprus category-eurovision-news tag-cybc tag-cyprus-2 tag-elena-tsagrinou tag-eurovision-2021 tag-featured tag-internal-selection tag-sandro-nicolas"><div class="post-content clearfix"><p><strong>The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It&#8217;s the Greek young singer Elena Tsagrinou who will fly their flag this May in Rotterdam, with the song <em>El Diablo!</em></strong></p><style>.showMobile{display:none}.showDesktop{display:block}@media (max-width:767px){.showMobile{display:block}.showDesktop{display:none}}</style><div id="div-gpt-ad-1510691866308-4" class="showMobile"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-4'); });</script></div><p>Last June <strong>CyBC</strong> announced that its cooperation with <strong>Sandro Nicolas</strong> who was selected to represent them at the &#8211; finally cancelled &#8211; Eurovision Song Contest 2020 <a href="http://esctoday.com/180255/cyprus-cybc-confirms-new-artist-selection-for-eurovision-2021/">would not be renewed for 2021</a> and that Cyprus would be represented by a Cypriot artist, or by someone known in both Cyprus and Greece. The second scenario was what prevailed in the end. The whole selection process seems to have taken place under extreme secrecy, as there have been no recent rumors about the artist&#8217;s name.</p><p>Here&#8217;s their announcement:</p><h2><img class="size-large wp-image-181179 aligncenter" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20640%20366'%3E%3C/svg%3E" alt="" width="640" height="366" data-lazy-srcset="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-Elena-Tsagrinou-Cyprus-2021-1024x585.jpg?x52282 1024w, http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-Elena-Tsagrinou-Cyprus-2021-300x171.jpg?x52282 300w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-Elena-Tsagrinou-Cyprus-2021-1024x585.jpg" /><noscript><img class="size-large wp-image-181179 aligncenter" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-Elena-Tsagrinou-Cyprus-2021-1024x585.jpg" alt="" width="640" height="366" srcset="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-Elena-Tsagrinou-Cyprus-2021-1024x585.jpg?x52282 1024w, http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-Elena-Tsagrinou-Cyprus-2021-300x171.jpg?x52282 300w" sizes="(max-width: 640px) 100vw, 640px" /></noscript></h2><h2>About Elena Tsagrinou</h2><p><strong>Elena Tsagrinou</strong> was born in 1994 in Athens, Greece. Her first contact with the public was at the age of just 14, when she took part in <strong><em>Greece&#8217;s Got Talent</em></strong>, where she had a eventually reached the semi-finals. Some years later, in 2013, she joined the group <strong>OtherView</strong>, as their lead singer, with whom she rose to fame and further success. Five years later, she decided to pursue a solo career in the music industry by signing a contract with <strong>Panik Records</strong> and releasing her first personal single <em>Pame ap&#8217; tin arhi (Let&#8217;s go from the start)</em>, penned by the acclaimed <strong>Dimitris Kontopoulos</strong>, as well as <strong>Nikos Moraitis</strong>.</p><div class="fve-video-wrapper fve-image-embed fve-thumbnail-image youtube" style="padding-bottom:75%;"> <div class="rll-youtube-player" data-src="//www.youtube.com/embed/pDORhQf7yw4" data-id="pDORhQf7yw4" data-query="wmode=transparent&amp;modestbranding=1&amp;autohide=1&amp;showinfo=0&amp;rel=0"></div><noscript><iframe src="//www.youtube.com/embed/pDORhQf7yw4?wmode=transparent&#038;modestbranding=1&#038;autohide=1&#038;showinfo=0&#038;rel=0" width="100%" height="100%" frameborder="0" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe></noscript> </div><p>Several other singles followed, like <em>Paradisos (Heaven)</em>, <em>Logia (Words)</em> and <em>Amore</em>. She has joined forces with big names of the Greek music industry, such as <strong>Konstantinos Argiros</strong> and the band <strong>MELISSES</strong>. A few months ago, she also released the single <em>Pare me agalia (Give me a hug)</em>, with the hip hop artist <strong>Mike</strong>, who is also her partner.</p><div class="fve-video-wrapper fve-image-embed fve-thumbnail-image youtube" style="padding-bottom:75%;"> <div class="rll-youtube-player" data-src="//www.youtube.com/embed/qZQJeLAMpbM" data-id="qZQJeLAMpbM" data-query="wmode=transparent&amp;modestbranding=1&amp;autohide=1&amp;showinfo=0&amp;rel=0"></div><noscript><iframe src="//www.youtube.com/embed/qZQJeLAMpbM?wmode=transparent&#038;modestbranding=1&#038;autohide=1&#038;showinfo=0&#038;rel=0" width="100%" height="100%" frameborder="0" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe></noscript> </div><p>Elena is also experienced in TV presenting, as 4 years ago. she co-hosted <strong><em>The Voice of Greece</em></strong> together with<strong> Giorgos Kapoutzidis</strong>, who has been a Eurovision commentator for Greece in 2006 and every year since 2013 (except in 2018). She is currently running her own music show, the &#8220;KPOP stars&#8221; on MAD TV, the leading music TV station in both Greece and Cyprus.</p><h2>Meet the team behind <em>El Diablo</em></h2><p>Although we will be listening to the Cypriot entry in a few months from now, we already know that a very promising writing team is behind it. As stated in the announcement, the song is about &#8220;someone falling in love as bad as&#8230; <em>El Diablo!</em>&#8220;. <strong>Thomas Stengaard</strong>, who triumphed as a songwriter in 2013 with <strong>Emmelie de Forest</strong>&#8216;s <em>Only teardrops</em> and lifted Germany within the Top 5 with <strong>Michael Schulte</strong>&#8216;s <em>You let me walk alone</em>, Jimmy &#8220;Joker&#8221; Thornfeldt, who has written songs for worldwide-known artists such as <strong>Jennifer Lopez</strong>, <strong>Enrique Iglesias</strong> and <strong>Pitbull</strong>, <strong>Laurell Barker</strong>, who made it to the Top 5 for Switzerland with <strong>Luca Hanni</strong>’s <em>She got me </em>and the Brazilian-born singer, dancer and songwriter <strong>Oxa </strong>give the impression that Cyprus will claim to climb high on the scoreboard for another year and, why not, to its first victory.</p><p>The song will be unveiled by <strong>Panik Records</strong> in the first months of 2021.</p><p>As it was announced some time ago, the staging of the song will be entrusted to the world-famous <strong>Marvin Dietmann</strong>, who was also behind the victorious appearance of <strong>Conchita Wurst</strong> in 2014.</p><h2 class="o9v6fnle cxmmr5t8 oygrvhab hcukyx3x c1et5uql ii04i59q">Cyprus at the Eurovision Song Contest 2021</h2><div>The island of Aphrodite will compete in the first semi-final of Eurovision 2021, which is set to be held on Tuesday 18 May 2021.</div><div></div><div>The 65th Eurovision Song Contest will take place on <strong>18</strong>, <strong>20</strong> and<strong> 22 May 2021</strong> in Rotterdam, The Netherlands. The exact format of the contest will be decided a few weeks before, depending on the developments with the COVID-19 pandemic.</div><div id="div-gpt-ad-1510691866308-5" class="showMobile"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-5'); });</script></div><div class="alert alert-success call_to_action joinourteam">ESCToday is growing and always looks for new members to join our team! Feel free to drop us a line if you're interested! Use the <a href="http://esctoday.com/contact/" target="_blank">Contact Us page</a> or send us an email at <a href="mailto:vacancies@esctoday.com">vacancies@esctoday.com</a>!</div></div> <footer class="post-meta"><div class="tags-wrapper"><ul class="tags-widget clearfix"> <li class="trending">Tags:</li><li><a href="http://esctoday.com/tag/cybc/" rel="tag">CyBC</a></li><li><a href="http://esctoday.com/tag/cyprus-2/" rel="tag">cyprus</a></li><li><a href="http://esctoday.com/tag/elena-tsagrinou/" rel="tag">Elena Tsagrinou</a></li><li><a href="http://esctoday.com/tag/eurovision-2021/" rel="tag">Eurovision 2021</a></li><li><a href="http://esctoday.com/tag/featured/" rel="tag">featured</a></li><li><a href="http://esctoday.com/tag/internal-selection/" rel="tag">Internal selection</a></li><li><a href="http://esctoday.com/tag/sandro-nicolas/" rel="tag">Sandro Nicolas</a></li></ul></div><div class="share-wrapper clearfix"><div class="total-shares"> <em id="countUp">0</em> <div class="caption">SHARES</div> </div><div class="share-buttons"><a class="social-share facebook" href="javascript:dt_share('fb', 'Cyprus: It&#8217;s Elena Tsagrinou to Rotterdam!', 'The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It&#8217;s the Greek young...')"> <i class="fa fa-facebook"></i> <span class="alt-text">Share</span> </a><a class="social-share twitter" href="javascript:dt_share('tw', 'Cyprus: It&#8217;s Elena Tsagrinou to Rotterdam!', 'The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It&#8217;s the Greek young...')"> <i class="fa fa-twitter"></i> <span class="alt-text">Tweet</span> </a><a class="social-share google-plus" href="javascript:dt_share('gp', 'Cyprus: It&#8217;s Elena Tsagrinou to Rotterdam!', 'The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It&#8217;s the Greek young...')"> <i class="fa fa-google-plus"></i> <span class="alt-text"></span> </a><a class="social-share linkedin" href="javascript:dt_share('ln', 'Cyprus: It&#8217;s Elena Tsagrinou to Rotterdam!', 'The die is cast! The Cypriot broadcaster CyBC has already made its mind up for Eurovision 2021 and today is the day of the big announcement! It&#8217;s the Greek young...')"> <i class="fa fa-linkedin"></i> <span class="alt-text"></span> </a></div></div><div class="author-box clearfix"> <div class="author-avatar"> <a href="http://esctoday.com/author/eagadellisyahoo-gr/"> <img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2018/04/wsi-imageoptim-29871991_10216148318726806_3307035855505085382_o-150x150.jpg?x52282" /><noscript><img width="150" height="150" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2018/04/wsi-imageoptim-29871991_10216148318726806_3307035855505085382_o-150x150.jpg?x52282" class="attachment-thumbnail size-thumbnail" alt="" /></noscript> </a> </div> <div class="author-info"> <h3><a href="http://esctoday.com/author/eagadellisyahoo-gr/">Stratos Agadellis</a></h3><p class="author-position">Senior Editor</p> <p>Chemist. Restless spirit. Book and food lover. Eurovision passionate since childhood.</p> <div class="author-contact"> <a href="https://www.facebook.com/stratos.agadellis" target="_blank"><i class="fa fa-facebook fa-lg" title="Facebook"></i></a><a href="https://www.instagram.com/stratosag/" target="_blank"><i class="fa fa-instagram fa-lg" title="Instagram"></i></a> </div> </div></div> <h3 class="block-title"><span>Comments:</span></h3><div class="fb-comments" id="comments" data-href="http://esctoday.com/181176/cyprus-its-elena-tsagrinou-to-rotterdam/" data-width="100%" data-numposts="5"></div><div class="row"> <div class="post-nav-wrapper clearfix"> <div class="col-md-6 omega"> <div class="previous-post"> <div class="post-nav-label"> <i class="fa fa-angle-left"></i> Previous post </div> <a href="http://esctoday.com/181165/lithuania-the-roop-will-compete-in-the-national-selection-for-eurovision-2021/">Lithuania: The Roop will compete in the national selection for Eurovision 2021</a> </div> </div> <div class="col-md-6 alpha"> </div> </div></div></footer><div class="related-posts clearfix"><h3 class="block-title"><span>Related posts</span></h3><div class="row "><div class="col-md-12"><article class="simple-post clearfix post-181165 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-lithuania category-eurovision-news tag-eurovision tag-eurovision-2021 tag-featured tag-eurovision-news-lithuania tag-the-roop"><div class="simple-thumb"><a href="http://esctoday.com/181165/lithuania-the-roop-will-compete-in-the-national-selection-for-eurovision-2021/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-the-roop-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-the-roop-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript></a></div><header><h3 class="h4"><a href="http://esctoday.com/181165/lithuania-the-roop-will-compete-in-the-national-selection-for-eurovision-2021/">Lithuania: The Roop will compete in the national selection for Eurovision 2021</a></h3><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/sanjay-jiandani/">Sanjay (Sergio) Jiandani</a></span> - <span class="article-date"><i class="fa fa-clock-o"></i> November 23, 2020 9:00 am</span></p></header></article></div></div><div class="row "><div class="col-md-12"><article class="simple-post clearfix post-180784 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-the-netherlands-2021 tag-eurovision tag-eurovision-2021 tag-featured tag-timeline"><div class="simple-thumb"><a href="http://esctoday.com/180784/eurovision-2021-the-provisional-timeline-rotterdam-here-we-come/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/09/wsi-imageoptim-rotterdam-255x180.jpeg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/09/wsi-imageoptim-rotterdam-255x180.jpeg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript></a></div><header><h3 class="h4"><a href="http://esctoday.com/180784/eurovision-2021-the-provisional-timeline-rotterdam-here-we-come/">Eurovision 2021: The provisional timeline; Rotterdam here we come!</a></h3><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/sanjay-jiandani/">Sanjay (Sergio) Jiandani</a></span> - <span class="article-date"><i class="fa fa-clock-o"></i> November 20, 2020 10:20 am</span></p></header></article></div></div><div class="row "><div class="col-md-12"><article class="simple-post clearfix post-181156 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-the-netherlands-2021 tag-eurovision-news-ebu tag-eurovision tag-eurovision-2021"><div class="simple-thumb"><a href="http://esctoday.com/181156/esc-2021-the-ebu-sheds-more-light-on-the-live-on-tape-performances/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/12/wsi-imageoptim-unnamed-2-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/12/wsi-imageoptim-unnamed-2-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript></a></div><header><h3 class="h4"><a href="http://esctoday.com/181156/esc-2021-the-ebu-sheds-more-light-on-the-live-on-tape-performances/">ESC 2021: The EBU sheds more light on the &#8216;Live On Tape Performances&#8217;</a></h3><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/sanjay-jiandani/">Sanjay (Sergio) Jiandani</a></span> - <span class="article-date"><i class="fa fa-clock-o"></i> November 20, 2020 10:00 am</span></p></header></article></div></div><div class="row "><div class="col-md-12"><article class="simple-post clearfix post-181159 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-eurovision-news-the-netherlands tag-eurovision tag-eurovision-2021 tag-jeangu-macrooy"><div class="simple-thumb"><a href="http://esctoday.com/181159/the-netherlands-jeangu-macrooy-will-perform-23-in-the-grand-final-2/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-jeangu-22-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-jeangu-22-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript></a></div><header><h3 class="h4"><a href="http://esctoday.com/181159/the-netherlands-jeangu-macrooy-will-perform-23-in-the-grand-final-2/">The Netherlands: Jeangu Macrooy will perform #23 in the Grand Final</a></h3><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/sanjay-jiandani/">Sanjay (Sergio) Jiandani</a></span> - <span class="article-date"><i class="fa fa-clock-o"></i> November 19, 2020 7:20 pm</span></p></header></article></div></div></div></article></div></div> </div> </div> <div class="col-md-4 dt_sidebar"> <div class="widget-area" role="complementary"> <div class="theiaStickySidebar"> <aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="div-gpt-ad-1510691866308-0" style="margin-bottom:20px"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-0'); });</script></div></div></aside><aside id="social_widget-2" class="widget widget_social_widget"><ul class="social-list"><li class="social-facebook"><a href="http://facebook.com/esctoday" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Facebook"><i class="fa fa-facebook"></i></a></li><li class="social-twitter"><a href="http://twitter.com/esctoday" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Twitter"><i class="fa fa-twitter"></i></a></li><li class="social-youtube"><a href="http://youtube.com/esctodaytv" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Youtube"><i class="fa fa-youtube"></i></a></li><li class="social-linkedin"><a href="https://www.linkedin.com/company/506308" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Linkedin"><i class="fa fa-linkedin"></i></a></li><li class="social-instagram"><a href="https://www.instagram.com/esctoday" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Instagram"><i class="fa fa-instagram"></i></a></li></ul></aside><aside id="wysiwyg_widgets_widget-12" class="widget widget_wysiwyg_widgets_widget"><p style="text-align: center;"><a href="http://esctoday.com/eurovision-news-infe/infe-poll-2020/"><img class="img-responsive aligncenter wp-image-129594 size-full" title="INFE Poll 2019" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="infe_poll_2019" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/04/wsi-imageoptim-infepoll2020-big-540x355.png" /><noscript><img class="img-responsive aligncenter wp-image-129594 size-full" title="INFE Poll 2019" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/04/wsi-imageoptim-infepoll2020-big-540x355.png" alt="infe_poll_2019" /></noscript></a></p></aside><aside id="wysiwyg_widgets_widget-11" class="widget widget_wysiwyg_widgets_widget"><p><a href="http://esctoday.com/eurovision-news-ogae/eurovision-news-ogae-poll-2019/"><img class="img-responsive aligncenter wp-image-173460 size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20540%20355'%3E%3C/svg%3E" alt="OGAE Poll 2019 - at ESCToday.com" width="540" height="355" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/03/wsi-imageoptim-OGAE-Poll-2019-540x355.jpg" /><noscript><img class="img-responsive aligncenter wp-image-173460 size-large" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/03/wsi-imageoptim-OGAE-Poll-2019-540x355.jpg" alt="OGAE Poll 2019 - at ESCToday.com" width="540" height="355" /></noscript></a></p></aside><aside id="wysiwyg_widgets_widget-5" class="widget widget_wysiwyg_widgets_widget"><p><a href="http://esctoday.com/eurovision-news-opinions/eurovision-news-op_esc/"><img class="img-responsive aligncenter wp-image-129587 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20480%20260'%3E%3C/svg%3E" alt="OP_ESC" width="480" height="260" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2016/03/op_esc_2016.jpg?x63164" /><noscript><img class="img-responsive aligncenter wp-image-129587 size-full" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2016/03/op_esc_2016.jpg?x63164" alt="OP_ESC" width="480" height="260" /></noscript></a></p></aside><aside id="tabs_widget-5" class="widget widget_tabs_widget"> <ul class="nav nav-tabs" role="tablist" id="widget-tab"> <li role="presentation" class="active"><a href="#dtblock15ac854444808a13bc52defeb8bbfc10" aria-controls="dtblock15ac854444808a13bc52defeb8bbfc10" role="tab" data-toggle="tab" aria-expanded="true">Popular</a></li> </ul> <div class="tab-content"> <div role="tabpanel" class="tab-pane animated fadeIn clearfix active" id="dtblock15ac854444808a13bc52defeb8bbfc10"> <div class=""> <div id="dtblock15ac854444808a13bc52defeb8bbfc10kkk"><article class="widget-post clearfix post-180784 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-the-netherlands-2021 tag-eurovision tag-eurovision-2021 tag-featured tag-timeline"> <div class="simple-thumb"> <a href="http://esctoday.com/180784/eurovision-2021-the-provisional-timeline-rotterdam-here-we-come/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/09/wsi-imageoptim-rotterdam-255x180.jpeg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/09/wsi-imageoptim-rotterdam-255x180.jpeg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/180784/eurovision-2021-the-provisional-timeline-rotterdam-here-we-come/">Eurovision 2021: The provisional timeline; Rotterdam here we come!</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 2,585 views</p> </header></article><article class="widget-post clearfix post-181153 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-the-netherlands-2021 tag-eurovision-news-ebu tag-eurovision tag-eurovision-2021"> <div class="simple-thumb"> <a href="http://esctoday.com/181153/esc-2021-competing-acts-to-record-live-on-tape-performances-prior-to-the-contest/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/02/wsi-imageoptim-led-screen-1-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/02/wsi-imageoptim-led-screen-1-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181153/esc-2021-competing-acts-to-record-live-on-tape-performances-prior-to-the-contest/">ESC 2021: Competing acts to record &#8216;Live On Tape Performances&#8217; prior to the contest</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 523 views</p> </header></article><article class="widget-post clearfix post-181159 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-eurovision-news-the-netherlands tag-eurovision tag-eurovision-2021 tag-jeangu-macrooy"> <div class="simple-thumb"> <a href="http://esctoday.com/181159/the-netherlands-jeangu-macrooy-will-perform-23-in-the-grand-final-2/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-jeangu-22-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-jeangu-22-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181159/the-netherlands-jeangu-macrooy-will-perform-23-in-the-grand-final-2/">The Netherlands: Jeangu Macrooy will perform #23 in the Grand Final</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 317 views</p> </header></article><article class="widget-post clearfix post-181121 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-the-netherlands-2021 tag-eurovision tag-eurovision-2021 tag-featured"> <div class="simple-thumb"> <a href="http://esctoday.com/181121/eurovision-2021-esc-2020-semi-final-line-up-to-remain-the-same-for-esc-2021/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-hl-5-1-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-hl-5-1-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181121/eurovision-2021-esc-2020-semi-final-line-up-to-remain-the-same-for-esc-2021/">Eurovision 2021: ESC 2020 Semi-final line up to remain the same for ESC 2021</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 602 views</p> </header></article><article class="widget-post clearfix post-181117 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-albania category-eurovision-news tag-albania-2 tag-eurovision tag-festivali-i-kenges-59"> <div class="simple-thumb"> <a href="http://esctoday.com/181117/albania-rtsh-releases-the-fest-59-entries/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-fest-59-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-fest-59-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181117/albania-rtsh-releases-the-fest-59-entries/">Albania: RTSH releases the Fest 59 entries</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 896 views</p> </header></article><article class="widget-post clearfix post-181110 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-estonia category-eurovision-news tag-eesti-laul-2021 tag-eurovision-news-estonia tag-eurovision"> <div class="simple-thumb"> <a href="http://esctoday.com/181110/estonia-err-unveils-twelve-more-eesti-laul-2021-semifinalists/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-eesti-laul-2021-2-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-eesti-laul-2021-2-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181110/estonia-err-unveils-twelve-more-eesti-laul-2021-semifinalists/">Estonia: ERR unveils twelve more Eesti Laul 2021 semifinalists!</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 771 views</p> </header></article><article class="widget-post clearfix post-181106 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-estonia category-eurovision-news tag-eesti-laul-2021 tag-eurovision-news-estonia tag-eurovision"> <div class="simple-thumb"> <a href="http://esctoday.com/181106/estonia-err-unveils-first-twelve-eesti-laul-2021-semifinalists/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-eesti-laul-2021-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/11/wsi-imageoptim-eesti-laul-2021-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181106/estonia-err-unveils-first-twelve-eesti-laul-2021-semifinalists/">Estonia: ERR unveils first twelve Eesti Laul 2021 semifinalists</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 1,016 views</p> </header></article><article class="widget-post clearfix post-181091 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-albania category-eurovision-news tag-albania-2 tag-eurovision tag-festivali-i-kenges-2020"> <div class="simple-thumb"> <a href="http://esctoday.com/181091/albania-festivali-i-kenges-59-to-be-held-in-an-open-air-venue-in-december/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/08/wsi-imageoptim-arilena-ara-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/08/wsi-imageoptim-arilena-ara-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181091/albania-festivali-i-kenges-59-to-be-held-in-an-open-air-venue-in-december/">Albania: Festivali i Këngës 59 to be held in an open air venue in December</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 385 views</p> </header></article><article class="widget-post clearfix post-181086 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-estonia category-eurovision-news tag-eesti-laul-2021 tag-eurovision-news-estonia tag-eurovision"> <div class="simple-thumb"> <a href="http://esctoday.com/181086/estonia-eesti-laul-2021-dates-confirmed-all-three-shows-in-tallinn/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/03/wsi-imageoptim-uku-suviste-2-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/03/wsi-imageoptim-uku-suviste-2-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181086/estonia-eesti-laul-2021-dates-confirmed-all-three-shows-in-tallinn/">Estonia: Eesti Laul 2021 dates confirmed: all three shows in Tallinn</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 534 views</p> </header></article><article class="widget-post clearfix post-181070 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-cyprus category-eurovision-news tag-cyprus-2 tag-eleni-foureira tag-eurovision"> <div class="simple-thumb"> <a href="http://esctoday.com/181070/cyprus-eleni-foureira-sets-the-dancefloor-on-fire-with-light-it-up/"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/10/wsi-imageoptim-foureira-lit-255x180.jpg?x52282" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/10/wsi-imageoptim-foureira-lit-255x180.jpg?x52282" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/181070/cyprus-eleni-foureira-sets-the-dancefloor-on-fire-with-light-it-up/">Cyprus: Eleni Foureira sets the dancefloor on fire with &#8216;Light It Up&#8217;</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 531 views</p> </header></article></div> </div> </div> </div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="div-gpt-ad-1510691866308-1" style="margin-top:20px;"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-1'); });</script></div></div></aside> </div></div> </div> </div> </div> <div class="mag-content clearfix"> <div class="row"> <div class="col-md-12"> <div class="content-bottom-wrapper"><div id="div-gpt-ad-1510691866308-3" class="showDesktop"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-3'); });</script></div></div> </div></div></div> </div> </div><footer class="footer source-org vcard copyright clearfix" id="footer"> <div class="footer-main"> <div class="fixed-main"> <div class="container"> <div class="mag-content"> <div class="row"> <div class="col-md-5"> <div id="wysiwyg_widgets_widget-3" class="footer-block clearfix widget_wysiwyg_widgets_widget"><h3 class="footer-title">About us</h3><p><span style="color: #ffffff;">ESCToday was founded in 1999 and since then it delivers Eurovision Song Contest news, polls, interviews, charts and exclusivities on a daily basis.</span></p><p><span style="color: #ffffff;"><a style="color: #ffffff;" href="//esctoday.com/about-us/"><strong>About Esctoday</strong></a></span></p><p><span style="color: #ffffff;"><strong><a style="color: #ffffff;" href="//esctoday.com/about-us/the-team/">The team behind</a></strong></span></p></div> </div> <div class="col-md-3"> <div id="nav_menu-2" class="footer-block clearfix widget_nav_menu"><h3 class="footer-title">Categories</h3><div class="menu-foote_menu-container"><ul id="menu-foote_menu" class="menu"><li id="menu-item-110457" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110457"><a href="http://esctoday.com/eurovision-news/">Eurovision News</a></li><li id="menu-item-110459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110459"><a href="http://esctoday.com/eurovision-news/eurovision-news-past-participants/">Participants News</a></li><li id="menu-item-110456" class="menu-item menu-item-type-post_type_archive menu-item-object-participant menu-item-110456"><a href="http://esctoday.com/participant/">Eurovision Participants</a></li><li id="menu-item-110458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110458"><a href="http://esctoday.com/eurovision-news-ogae/">Fans</a></li></ul></div></div> </div> <div class="col-md-4"> <div id="text-3" class="footer-block clearfix widget_text"><h3 class="footer-title">Social Media</h3><div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/esctoday/" data-tabs="messages, events" data-height="350" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/esctoday/"><a href="https://www.facebook.com/esctoday/">Esctoday</a></blockquote></div></div></div></div> </div> </div> </div> </div> </div> </div> <div class="footer-bottom"> <div class="fixed-main"> <div class="container"> <div class="mag-content"> <div class="row"> <div class="col-md-6"> Copyright ESCToday © 2019. All Rights Reserved </div> <div class="col-md-6"> <div class="social-icons pull-right"> <a href="http://facebook.com/esctoday" title="" data-original-title="Facebook" target="_blank"><i class="fa fa-facebook"></i></a><a href="http://twitter.com/esctoday" title="" data-original-title="Twitter" target="_blank"><i class="fa fa-twitter"></i></a><a href="http://youtube.com/esctodaytv" title="" data-original-title="Youtube" target="_blank"><i class="fa fa-youtube"></i></a><a href="" title="" data-original-title="Google+" target="_blank"><i class="fa fa-google-plus"></i></a><a href="https://www.linkedin.com/company/506308" title="" data-original-title="Linkedin" target="_blank"><i class="fa fa-linkedin"></i></a><a href="https://www.instagram.com/esctoday" title="" data-original-title="Instagram" target="_blank"><i class="fa fa-instagram"></i></a> </div> </div></div> </div> </div> </div> </div> </footer></div><div class="mobile-overlay" id="mobile-overlay"></div><nav id="mobile-nav" class="mm-menu mm-offcanvas"><div><ul id="menu-main-menu-1" class=""><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-38557"><a href="http://esctoday.com/eurovision-news/">News</a><ul class="sub-menu"><li class="countries-cols menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-38559"><a href="http://esctoday.com/eurovision-news-countries/">All the Countries</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108268"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-albania/">Albania</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108269"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-andorra/">Andorra</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108270"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-armenia/">Armenia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108271"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-australia/">Australia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108272"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-austria/">Austria</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108273"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-azerbaijan/">Azerbaijan</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108274"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-belarus/">Belarus</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108275"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-belgium/">Belgium</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108276"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-bosnia-herzegovina/">Bosnia &#038; Herzegovina</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108277"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-bulgaria/">Bulgaria</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108278"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-croatia/">Croatia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-108279"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-cyprus/">Cyprus</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108280"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-czech-republic/">Czech Republic</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108281"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-denmark/">Denmark</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108282"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-estonia/">Estonia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108283"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-finland/">Finland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108284"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-france/">France</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108286"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-georgia/">Georgia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108287"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-germany/">Germany</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108288"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-greece/">Greece</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108289"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-hungary/">Hungary</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108290"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-iceland/">Iceland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108291"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-ireland/">Ireland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108292"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-israel/">Israel</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108293"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-italy/">Italy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108294"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-latvia/">Latvia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108295"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-lebanon/">Lebanon</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108296"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-liechtenstein/">Liechtenstein</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108297"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-lithuania/">Lithuania</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108298"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-luxembourg/">Luxembourg</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108299"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-malta/">Malta</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108300"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-moldova/">Moldova</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108301"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-monaco/">Monaco</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108302"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-montenegro/">Montenegro</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108303"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-morocco/">Morocco</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108285"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-north-macedonia/">North Macedonia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108304"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-norway/">Norway</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108305"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-poland/">Poland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108306"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-portugal/">Portugal</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108307"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-romania/">Romania</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108308"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-russia/">Russia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108309"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-san-marino/">San Marino</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108310"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-serbia/">Serbia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108311"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-serbia-montenegro/">Serbia &#038; Montenegro</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108312"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-slovakia/">Slovakia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108313"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-slovenia/">Slovenia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108314"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-spain/">Spain</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108315"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-sweden/">Sweden</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108316"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-switzerland/">Switzerland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108317"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-the-netherlands/">The Netherlands</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108318"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-turkey/">Turkey</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108319"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-ukraine/">Ukraine</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108320"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-united-kingdom/">United Kingdom</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108321"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-yugoslavia/">Yugoslavia</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38561"><a href="http://esctoday.com/eurovision-news/eurovision-news-past-participants/">News about Past Participants</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38560"><a href="http://esctoday.com/eurovision-news-ogae/">News from Fan Clubs</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38562"><a href="http://esctoday.com/eurovision-news-archive/">News Archive/History</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-180984"><a href="http://esctoday.com/eurovision-news/the-netherlands-2021/">Rotterdam 2021</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-180985"><a href="http://esctoday.com/participant?contest_year=2021">Participants</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-137361"><a href="#">Previous Years</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177171"><a href="http://esctoday.com/eurovision-news/eurovision-news-the-netherlands-2020/">Rotterdam 2020</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-177172"><a href="http://esctoday.com/participant?contest_year=2020">Participants</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-171446"><a href="http://esctoday.com/eurovision-news/eurovision-news-israel-2019/">Tel Aviv 2019</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171447"><a href="http://esctoday.com/participant?contest_year=2019">Participants</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-148277"><a href="http://esctoday.com/eurovision-news/eurovision-news-portugal-2018/">Portugal 2018</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171445"><a href="http://esctoday.com/participant?contest_year=2018">Participants</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171444"><a href="http://esctoday.com/eurovision-news-discover-lisbon/">Discover Lisbon</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-137362"><a href="http://esctoday.com/eurovision-news/eurovision-news-ukraine-2017/">Ukraine 2017</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-162531"><a href="http://esctoday.com/participant?contest_year=2017">Participants</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162530"><a href="http://esctoday.com/eurovision-news-discover-kyiv/">Discover Kyiv</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-104297"><a href="http://esctoday.com/eurovision-news/eurovision-news-sweden-2016/">Sweden 2016</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-137583"><a href="http://esctoday.com/participant?contest_year=2016">Participants</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137584"><a href="http://esctoday.com/eurovision-news-discover-stockholm/">Discover Stockholm</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-108242"><a href="http://esctoday.com/eurovision-news/eurovision-news-austria-2015/">Austria 2015</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-108246"><a href="#">Participants</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108245"><a href="http://esctoday.com/participants/eurovision-song-contest-2015-semi-final-1/">Eurovision Song Contest 2015 – Semi-final 1</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108244"><a href="http://esctoday.com/participants/eurovision-song-contest-2015-semi-final-2/">Eurovision Song Contest 2015 – Semi-final 2</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108243"><a href="http://esctoday.com/eurovision-song-contest-2015-grand-final/">Eurovision Song Contest 2015 – Grand Final</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108247"><a href="http://esctoday.com/eurovision-news-discover-vienna/">Discover Vienna</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108248"><a href="http://esctoday.com/eurovision-news-specials/eurovision-news-video-message/">Eurostar&#8217;s Video Messages</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142157"><a href="http://esctoday.com/contact/">Contact Us</a></li></ul><div class="mobile-nav-footer"><form role="search" method="get" class="search-form" action="http://esctoday.com/"><div class="input-group"><span class="screen-reader-text">Search for:</span><input type="search" class="form-control" placeholder="Search &hellip;" value="" name="s" /> <span class="input-group-btn"><button type="submit" class="btn btn-default" value="Enter your search text..." ><i class="fa fa-search"></i></button></span></div></form></div></div></nav><script>jQuery(".sb-search").on('click', function(){console.log('clicked');new UISearch(document.getElementById("sb-search"));});</script><script>(function(d, s, id) {var js, fjs = d.getElementsByTagName(s)[0];if (d.getElementById(id)) return;js = d.createElement(s); js.id = id;js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&version=v2.5";
fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));</script><link rel='stylesheet' id='dynamic-css-css' href='http://esctoday.com/wp-content/themes/esctoday/css/redux-theme.css?x52282' type='text/css' media='all' /><link rel='stylesheet' id='dt_wp_admin_css-css' href='http://esctoday.com/wp-content/themes/esctoday/css/custom-meta.css?x52282' type='text/css' media='all' /><link rel='stylesheet' id='main-style-theme-css' href='http://esctoday.com/wp-content/themes/esctoday/theme.css?x52282' type='text/css' media='all' /><script type='text/javascript'>
var wpcf7 = {"apiSettings":{"root":"http:\/\/esctoday.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
</script><script type='text/javascript' src='http://esctoday.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?x52282'></script><script type='text/javascript'>
var viewsCacheL10n = {"admin_ajax_url":"http:\/\/esctoday.com\/wp-admin\/admin-ajax.php","post_id":"181176"};
</script><script type='text/javascript' src='http://esctoday.com/wp-content/plugins/wp-postviews/postviews-cache.js?x52282'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lf0vZAUAAAAALAij3_ilXrgx3ZNj-_aK0RVbmmi'></script><script type='text/javascript' src='http://esctoday.com/wp-content/themes/esctoday/js/plugins.js?x52282'></script><script type='text/javascript' src='http://esctoday.com/wp-content/themes/esctoday/css/plugins/bootstrap/js/bootstrap.min.js?x52282'></script><script type='text/javascript' src='http://esctoday.com/wp-includes/js/wp-embed.min.js?x52282'></script><script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?' async='async'></script><script type='text/javascript' src='//cdn.playbuzz.com/widget/feed.js'></script><script type='text/javascript' src='http://esctoday.com/wp-content/themes/esctoday/js/admin.js?x52282'></script><script type="text/javascript">( function( sitekey, actions ) {document.addEventListener( 'DOMContentLoaded', function( event ) {var wpcf7recaptcha = {execute: function( action ) {grecaptcha.execute(
sitekey,{ action: action }).then( function( token ) {var event = new CustomEvent( 'wpcf7grecaptchaexecuted', {detail: {action: action,token: token,},} );document.dispatchEvent( event );} );},executeOnHomepage: function() {wpcf7recaptcha.execute( actions[ 'homepage' ] );},executeOnContactform: function() {wpcf7recaptcha.execute( actions[ 'contactform' ] );},};grecaptcha.ready(
wpcf7recaptcha.executeOnHomepage
);document.addEventListener( 'change',wpcf7recaptcha.executeOnContactform, false
);document.addEventListener( 'wpcf7submit',wpcf7recaptcha.executeOnHomepage, false
);} );document.addEventListener( 'wpcf7grecaptchaexecuted', function( event ) {var fields = document.querySelectorAll(
"form.wpcf7-form input[name='g-recaptcha-response']"
);for ( var i = 0; i < fields.length; i++ ) {var field = fields[ i ];field.setAttribute( 'value', event.detail.token );}} );} )(
'6Lf0vZAUAAAAALAij3_ilXrgx3ZNj-_aK0RVbmmi',{"homepage":"homepage","contactform":"contactform"});</script><div id="cookie-notice" role="banner" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: rgba(0,0,0,1);"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap button" aria-label="Ok">Ok</a></span><a href="javascript:void(0);" id="cn-close-notice" data-cookie-set="accept" class="cn-close-icon" aria-label="Ok"></a></div></div><script>window.lazyLoadOptions = {elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src: "lazy-src",data_srcset: "lazy-srcset",data_sizes: "lazy-sizes",class_loading: "lazyloading",class_loaded: "lazyloaded",threshold: 300,callback_loaded: function(element) {if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {if (element.classList.contains("lazyloaded") ) {if (typeof window.jQuery != "undefined") {if (jQuery.fn.fitVids) {jQuery(element).parent().fitVids();}}}}}};window.addEventListener('LazyLoad::Initialized', function (e) {var lazyLoadInstance = e.detail.instance;if (window.MutationObserver) {var observer = new MutationObserver(function(mutations) {var image_count = 0;var iframe_count = 0;var rocketlazy_count = 0;mutations.forEach(function(mutation) {for (i = 0; i < mutation.addedNodes.length; i++) {if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {return;}if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {return;}images = mutation.addedNodes[i].getElementsByTagName('img');is_image = mutation.addedNodes[i].tagName == "IMG";iframes = mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe = mutation.addedNodes[i].tagName == "IFRAME";rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count += images.length;iframe_count += iframes.length;rocketlazy_count += rocket_lazy.length;if(is_image){image_count += 1;}if(is_iframe){iframe_count += 1;}}} );if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){lazyLoadInstance.update();}} );var b      = document.getElementsByTagName("body")[0];var config = { childList: true, subtree: true };observer.observe(b, config);}}, false);</script><script data-no-minify="1" async src="http://esctoday.com/wp-content/plugins/rocket-lazy-load/assets/js/16.1/lazyload.min.js?x52282"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script></body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced 
Content Delivery Network via S3-compatible: esct2019.storage.googleapis.com

Served from: esctoday.com @ 2020-11-25 09:12:32 by W3 Total Cache
-->