<!doctype html><html lang="en-US"><head><meta charset="UTF-8"><meta property="fb:pages" content="12622425949" /><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="http://esctoday.com/xmlrpc.php"><meta name="google-site-verification" content="v84ZTceatGXkFX9kMkQ792qROrAtxYOvO54Q-ixaV6A" /><link rel="apple-touch-icon" sizes="180x180" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/favicon-16x16.png"><link rel="manifest" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/site.webmanifest"><link rel="mask-icon" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/safari-pinned-tab.svg" color="#da532c"><link rel="shortcut icon" href="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/favicon.ico"><meta name="msapplication-TileColor" content="#da532c"><meta name="msapplication-config" content="http://esct2019.storage.googleapis.com/wp-content/uploads/favicons/browserconfig.xml"><meta name="theme-color" content="#ffffff"><title>Finland: YLE unveils the UMK 2020 candidates</title> <script>
if ( typeof WebFontConfig === "undefined" ) {WebFontConfig = new Object();}WebFontConfig['google'] = {families: ['Roboto:100,300,400,500,700,900,100italic,300italic,400italic,500italic,700italic,900italic', 'Exo+2:100,200,300,400,500,600,700,800,900,100italic,200italic,300italic,400italic,500italic,600italic,700italic,800italic,900italic&amp;subset=latin-ext']};(function() {var wf = document.createElement( 'script' );wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
wf.type = 'text/javascript';wf.async = 'true';var s = document.getElementsByTagName( 'script' )[0];s.parentNode.insertBefore( wf, s );})();</script> <meta name="description" content="Eurovision news: Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020"/><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="http://esctoday.com/178561/finland-yle-unveils-the-umk-2020-candidates/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Finland: YLE unveils the UMK 2020 candidates" /><meta property="og:description" content="Eurovision news: Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020" /><meta property="og:url" content="http://esctoday.com/178561/finland-yle-unveils-the-umk-2020-candidates/" /><meta property="og:site_name" content="Eurovision News, Polls and Information by ESCToday" /><meta property="article:publisher" content="http://facebook.com/esctoday" /><meta property="article:author" content="https://www.facebook.com/jiandani.sergio" /><meta property="article:tag" content="eurovision" /><meta property="article:tag" content="Eurovision 2020" /><meta property="article:tag" content="UMK 2020" /><meta property="article:section" content="Finland" /><meta property="article:published_time" content="2020-01-21T12:30:39+00:00" /><meta property="article:modified_time" content="2020-01-21T12:40:15+00:00" /><meta property="og:updated_time" content="2020-01-21T12:40:15+00:00" /><meta property="fb:app_id" content="1800027680295693" /><meta property="og:image" content="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-umk-2020.jpg?x80666" /><meta property="og:image:width" content="1280" /><meta property="og:image:height" content="800" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Eurovision news: Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020" /><meta name="twitter:title" content="Finland: YLE unveils the UMK 2020 candidates" /><meta name="twitter:site" content="@esctoday" /><meta name="twitter:image" content="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-umk-2020.jpg?x80666" /><meta name="twitter:creator" content="@sergiosanj1" /><script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"http://esctoday.com/#website","url":"http://esctoday.com/","name":"Eurovision News, Polls and Information by ESCToday","potentialAction":{"@type":"SearchAction","target":"http://esctoday.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://esctoday.com/178561/finland-yle-unveils-the-umk-2020-candidates/#primaryimage","url":"http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-umk-2020.jpg?x80666","width":1280,"height":800},{"@type":"WebPage","@id":"http://esctoday.com/178561/finland-yle-unveils-the-umk-2020-candidates/#webpage","url":"http://esctoday.com/178561/finland-yle-unveils-the-umk-2020-candidates/","inLanguage":"en-US","name":"Finland: YLE unveils the UMK 2020 candidates","isPartOf":{"@id":"http://esctoday.com/#website"},"primaryImageOfPage":{"@id":"http://esctoday.com/178561/finland-yle-unveils-the-umk-2020-candidates/#primaryimage"},"datePublished":"2020-01-21T12:30:39+00:00","dateModified":"2020-01-21T12:40:15+00:00","author":{"@id":"http://esctoday.com/#/schema/person/c77a353a636335d12ba0152d0b76beae"},"description":"Eurovision news: Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020"},{"@type":["Person"],"@id":"http://esctoday.com/#/schema/person/c77a353a636335d12ba0152d0b76beae","name":"Sanjay (Sergio) Jiandani","description":"Sanjay (Sergio) joined esctoday.com in December 2006 as an editor. He was appointed as the Head of Press of ESCToday.com in 2011. Hereafter in 2016 he was promoted as the Head of International Relations &amp; Communications at ESCToday. Sergio has covered the Eurovision Song Contest live 19 times since 2000, having worked for several international magazines and media outlets.","sameAs":["https://www.facebook.com/jiandani.sergio","https://es.linkedin.com/in/sanjay-jiandani-570284125","https://twitter.com/https://twitter.com/sergiosanj1"]}]}</script><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Eurovision News, Polls and Information by ESCToday &raquo; Feed" href="http://esctoday.com/feed/" /><link rel='stylesheet' id='contact-form-7-css' href='http://esct2019.storage.googleapis.com/wp-content/plugins/contact-form-7/includes/css/styles.css.gzip?x80666' type='text/css' media='all' /><link rel='stylesheet' id='cookie-notice-front-css' href='http://esct2019.storage.googleapis.com/wp-content/plugins/cookie-notice/css/front.min.css.gzip?x80666' type='text/css' media='all' /><link rel='stylesheet' id='wpt-twitter-feed-css' href='http://esct2019.storage.googleapis.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css.gzip?x80666' type='text/css' media='all' /><link rel='stylesheet' id='twitter-bootstrap-css' href='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/css/plugins/bootstrap/css/bootstrap.min.css.gzip?x80666' type='text/css' media='all' /><link rel='stylesheet' id='roboto-css' href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C500%2C700%2C900&#038;subset=cyrillic%2Cgreek' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css' href='http://esctoday.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?x80666' type='text/css' media='all' /><link rel='stylesheet' id='flag-icons-css' href='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/css/flags/flags.css.gzip?x80666' type='text/css' media='all' /><link rel='stylesheet' id='dt-style-css' href='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/style.css.gzip?x80666' type='text/css' media='all' /><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(http://esct2019.storage.googleapis.com/wp-content/plugins/rocket-lazy-load/assets/img/youtube.png?x80666) no-repeat;cursor:pointer}</style><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-includes/js/jquery/jquery.js.gzip?x80666'></script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-includes/js/jquery/jquery-migrate.min.js.gzip?x80666'></script><script type='text/javascript'>
var cnArgs = {"ajaxurl":"http:\/\/esctoday.com\/wp-admin\/admin-ajax.php","hideEffect":"fade","onScroll":"","onScrollOffset":"100","cookieName":"cookie_notice_accepted","cookieValue":"true","cookieTime":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"","cache":"1","refuse":"no","revoke_cookies":"0","revoke_cookies_opt":"automatic","secure":"0"};
</script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-content/plugins/cookie-notice/js/front.min.js.gzip?x80666'></script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/js/script.js.gzip?x80666'></script><script type='text/javascript'>
var aamLocal = {"nonce":"f3b3949537","ajaxurl":"http:\/\/esctoday.com\/wp-admin\/admin-ajax.php"};
</script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-content/plugins/advanced-access-manager/media/js/aam-login.js.gzip?x80666'></script><link rel='https://api.w.org/' href='http://esctoday.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://esctoday.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://esct2019.storage.googleapis.com/wp-includes/wlwmanifest.xml.gzip" /> <meta name="generator" content="WordPress 4.9.13" /><link rel='shortlink' href='https://esct.co/2tCAqtN' /><link rel="alternate" type="application/json+oembed" href="http://esctoday.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fesctoday.com%2F178561%2Ffinland-yle-unveils-the-umk-2020-candidates%2F" /><link rel="alternate" type="text/xml+oembed" href="http://esctoday.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fesctoday.com%2F178561%2Ffinland-yle-unveils-the-umk-2020-candidates%2F&#038;format=xml" /><style type="text/css">.fve-video-wrapper{position:relative;overflow:hidden;height:0;background-color:transparent;padding-bottom:56.25%;margin:0.5em 0}.fve-video-wrapper iframe,.fve-video-wrapper object,.fve-video-wrapper embed{position:absolute;display:block;top:0;left:0;width:100%;height:100%}.fve-video-wrapper a.hyperlink-image{position:relative;display:none}.fve-video-wrapper a.hyperlink-image img{position:relative;z-index:2;width:100%}.fve-video-wrapper a.hyperlink-image .fve-play-button{position:absolute;left:35%;top:35%;right:35%;bottom:35%;z-index:3;background-color:rgba(40,40,40,0.75);background-size:100% 100%;border-radius:10px}.fve-video-wrapper a.hyperlink-image:hover .fve-play-button{background-color:rgba(0,0,0,0.85)}</style> <script type="text/javascript">if (typeof ajaxurl === "undefined") {var ajaxurl = 'http://esctoday.com/wp-admin/admin-ajax.php';
}</script> <script type='text/javascript'>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script><script type='text/javascript'>fbq('init', '1032746690264235', [], {"agent": "wordpress-4.9.13-1.7.25"
});</script><script type='text/javascript'>fbq('track', 'PageView', []);</script><noscript><img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=1032746690264235&ev=PageView&noscript=1" /></noscript><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/><!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://esctoday.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?x80666" media="screen"><![endif]--> <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>window.OneSignal = window.OneSignal || [];OneSignal.push( function() {OneSignal.SERVICE_WORKER_UPDATER_PATH = "http://esct2019.storage.googleapis.com/OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH = "http://esct2019.storage.googleapis.com/OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };OneSignal.setDefaultNotificationUrl("http://esctoday.com");
var oneSignal_options = {};window._oneSignalInitOptions = oneSignal_options;oneSignal_options['wordpress'] = true;oneSignal_options['appId'] = '848f6e44-da03-4e90-a389-be7fc0298ddb';oneSignal_options['autoRegister'] = true;oneSignal_options['welcomeNotification'] = { };oneSignal_options['welcomeNotification']['title'] = "";oneSignal_options['welcomeNotification']['message'] = "";oneSignal_options['subdomainName'] = "esctoday";oneSignal_options['safari_web_id'] = "web.onesignal.auto.147da6f8-95e8-4f3e-9e77-8dc52e1c58f0";oneSignal_options['persistNotification'] = false;oneSignal_options['promptOptions'] = { };OneSignal.init(window._oneSignalInitOptions);});function documentInitOneSignal() {var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);}if (document.readyState === 'complete') {documentInitOneSignal();}else {window.addEventListener("load", function(event){documentInitOneSignal();});}</script><script type="text/javascript">var ajaxurl = "http://esctoday.com/wp-admin/admin-ajax.php";var dt_path = "http://esctoday.com/wp-content/themes/esctoday";var dt_paginated_blocks = [];var dt_paginated_blocks_type = [];var dt_paginated_blocks_items = [];</script><noscript><style type="text/css"> .wpb_animate_when_almost_visible{opacity:1}</style></noscript><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none !important}</style></noscript><script async="async" src="//www.googletagservices.com/tag/js/gpt.js"></script><script>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];</script><script>googletag.cmd.push(function() {googletag.defineSlot('/6787190/esctoday2_336x280_1', [350, 250], 'div-gpt-ad-1510691866308-0').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_336x280_2', [300, 250], 'div-gpt-ad-1510691866308-1').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_728x90_top', [728, 90], 'div-gpt-ad-1510691866308-2').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_728x90_2', [728, 90], 'div-gpt-ad-1510691866308-3').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_article_mobile_1', [300, 250], 'div-gpt-ad-1510691866308-4').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_article_mobile_2', [300, 250], 'div-gpt-ad-1510691866308-5').addService(googletag.pubads());googletag.defineSlot('/6787190/esctoday2_970x250//90', [970, 250], 'div-gpt-ad-1510691866308-6').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();googletag.pubads().collapseEmptyDivs();googletag.enableServices();});</script><script>jQuery(function ($) {$(document).ready(function () {if(['iPad', 'iPhone', 'iPod'].indexOf(navigator.platform) >= 0) {$('body').addClass('isIos');} else {$('body').addClass('isNotIos');}});});</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-28910909-1', 'auto');ga('require', 'displayfeatures');ga('send', 'pageview');</script><style>.isIos .parallax-image-holder{background-attachment:scroll}.grecaptcha-badge{display:none !important}</style></head><body class="post-template-default single single-post postid-178561 single-format-standard cookies-not-set sticky-header big-header top-header wide wpb-js-composer js-comp-ver-5.6 vc_responsive"><div id="fb-root"></div><div id="main"><header class="header-wrapper clearfix"><div class="header-top"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-12"><div class="menu-top_menu-container"><ul id="secondary-menu" class="top-menu pull-left"><li id="menu-item-107194" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107194"><a href="http://esctoday.com/eurovision-news/eurovision-news-sweden-2016/">News</a></li><li id="menu-item-108240" class="menu-item menu-item-type-post_type_archive menu-item-object-participant menu-item-108240"><a href="http://esctoday.com/participant/">Participants</a></li><li id="menu-item-130047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-130047"><a href="http://esctoday.com/contact/">Contact Us</a></li><li id="menu-item-139654" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139654"><a href="http://esctoday.com/eurovision-calendar/">Calendar</a></li></ul></div><div class="social-icons pull-right"><a href="http://facebook.com/esctoday" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Facebook" target="_blank"><i class="fa fa-facebook fa-lg"></i></a><a href="http://twitter.com/esctoday" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Twitter" target="_blank"><i class="fa fa-twitter fa-lg"></i></a><a href="http://youtube.com/esctodaytv" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Youtube" target="_blank"><i class="fa fa-youtube fa-lg"></i></a><a href="https://www.linkedin.com/company/506308" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Linkedin" target="_blank"><i class="fa fa-linkedin fa-lg"></i></a><a href="https://www.instagram.com/esctoday" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Instagram" target="_blank"><i class="fa fa-instagram fa-lg"></i></a></div></div></div></div></div></div><div class="header-mid"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-12"><div class="header-mid-wrapper clearfix"><div class="mid-logo-wrapper"><a class="logo" href="http://esctoday.com/" title="Eurovision News, Polls and Information by ESCToday - Your daily Eurovision news centre" rel="home"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Eurovision News, Polls and Information by ESCToday" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-logo-20years.png?x80666"/><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-logo-20years.png?x80666" alt="Eurovision News, Polls and Information by ESCToday"/></noscript></a></div><div class="header-banner"><div id="div-gpt-ad-1510691866308-2" class="showDesktop"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-2'); });</script></div></div></div></div></div></div></div></div><div class="header" id="header"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-12"><a class="navbar-toggle collapsed" id="nav-button" href="#mobile-nav"><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span></a><nav class="navbar mega-menu"><a class="logo" href="http://esctoday.com/" title="Eurovision News, Polls and Information by ESCToday - Your daily Eurovision news centre" rel="home"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Eurovision News, Polls and Information by ESCToday" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-logo-20years-small.png?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-logo-20years-small.png?x80666" alt="Eurovision News, Polls and Information by ESCToday" /></noscript></a><div id="main-nav" class="collapse navbar-collapse"><ul id="menu-main-menu" class="nav navbar-nav"><li id="menu-item-38557" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-38557 dropdown menu-color10885"><a href="http://esctoday.com/eurovision-news/" class="dropdown-toggle" aria-haspopup="true">News <span class="caret"></span></a><ul role="menu" class="dropdown-menu"><li id="menu-item-38559" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-38559 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news-countries/">All the Countries</a><ul role="menu" class="dropdown-menu"><li id="menu-item-108268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108268"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-albania/">Albania</a></li><li id="menu-item-108269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108269"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-andorra/">Andorra</a></li><li id="menu-item-108270" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108270"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-armenia/">Armenia</a></li><li id="menu-item-108271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108271"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-australia/">Australia</a></li><li id="menu-item-108272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108272"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-austria/">Austria</a></li><li id="menu-item-108273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108273"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-azerbaijan/">Azerbaijan</a></li><li id="menu-item-108274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108274"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-belarus/">Belarus</a></li><li id="menu-item-108275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108275"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-belgium/">Belgium</a></li><li id="menu-item-108276" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108276"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-bosnia-herzegovina/">Bosnia &#038; Herzegovina</a></li><li id="menu-item-108277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108277"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-bulgaria/">Bulgaria</a></li><li id="menu-item-108278" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108278"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-croatia/">Croatia</a></li><li id="menu-item-108279" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108279"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-cyprus/">Cyprus</a></li><li id="menu-item-108280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108280"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-czech-republic/">Czech Republic</a></li><li id="menu-item-108281" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108281"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-denmark/">Denmark</a></li><li id="menu-item-108282" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108282"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-estonia/">Estonia</a></li><li id="menu-item-108283" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-108283"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-finland/">Finland</a></li><li id="menu-item-108284" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108284"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-france/">France</a></li><li id="menu-item-108286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108286"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-georgia/">Georgia</a></li><li id="menu-item-108287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108287"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-germany/">Germany</a></li><li id="menu-item-108288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108288"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-greece/">Greece</a></li><li id="menu-item-108289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108289"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-hungary/">Hungary</a></li><li id="menu-item-108290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108290"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-iceland/">Iceland</a></li><li id="menu-item-108291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108291"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-ireland/">Ireland</a></li><li id="menu-item-108292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108292"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-israel/">Israel</a></li><li id="menu-item-108293" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108293"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-italy/">Italy</a></li><li id="menu-item-108294" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108294"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-latvia/">Latvia</a></li><li id="menu-item-108295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108295"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-lebanon/">Lebanon</a></li><li id="menu-item-108296" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108296"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-liechtenstein/">Liechtenstein</a></li><li id="menu-item-108297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108297"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-lithuania/">Lithuania</a></li><li id="menu-item-108298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108298"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-luxembourg/">Luxembourg</a></li><li id="menu-item-108299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108299"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-malta/">Malta</a></li><li id="menu-item-108300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108300"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-moldova/">Moldova</a></li><li id="menu-item-108301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108301"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-monaco/">Monaco</a></li><li id="menu-item-108302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108302"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-montenegro/">Montenegro</a></li><li id="menu-item-108303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108303"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-morocco/">Morocco</a></li><li id="menu-item-108285" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108285"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-north-macedonia/">North Macedonia</a></li><li id="menu-item-108304" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108304"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-norway/">Norway</a></li><li id="menu-item-108305" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108305"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-poland/">Poland</a></li><li id="menu-item-108306" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108306"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-portugal/">Portugal</a></li><li id="menu-item-108307" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108307"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-romania/">Romania</a></li><li id="menu-item-108308" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108308"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-russia/">Russia</a></li><li id="menu-item-108309" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108309"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-san-marino/">San Marino</a></li><li id="menu-item-108310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108310"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-serbia/">Serbia</a></li><li id="menu-item-108311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108311"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-serbia-montenegro/">Serbia &#038; Montenegro</a></li><li id="menu-item-108312" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108312"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-slovakia/">Slovakia</a></li><li id="menu-item-108313" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108313"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-slovenia/">Slovenia</a></li><li id="menu-item-108314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108314"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-spain/">Spain</a></li><li id="menu-item-108315" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108315"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-sweden/">Sweden</a></li><li id="menu-item-108316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108316"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-switzerland/">Switzerland</a></li><li id="menu-item-108317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108317"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-the-netherlands/">The Netherlands</a></li><li id="menu-item-108318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108318"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-turkey/">Turkey</a></li><li id="menu-item-108319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108319"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-ukraine/">Ukraine</a></li><li id="menu-item-108320" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108320"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-united-kingdom/">United Kingdom</a></li><li id="menu-item-108321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108321"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-yugoslavia/">Yugoslavia</a></li></ul></li><li id="menu-item-38561" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38561"><a href="http://esctoday.com/eurovision-news/eurovision-news-past-participants/">News about Past Participants</a></li><li id="menu-item-38560" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38560"><a href="http://esctoday.com/eurovision-news-ogae/">News from Fan Clubs</a></li><li id="menu-item-38562" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38562"><a href="http://esctoday.com/eurovision-news-archive/">News Archive/History</a></li></ul></li><li id="menu-item-177171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177171 dropdown menu-color11010"><a href="http://esctoday.com/eurovision-news/eurovision-news-the-netherlands-2020/" class="dropdown-toggle" aria-haspopup="true">Rotterdam 2020 <span class="caret"></span></a><ul role="menu" class="dropdown-menu"><li id="menu-item-177172" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-177172"><a href="http://esctoday.com/participant?contest_year=2020">Participants</a></li></ul></li><li id="menu-item-137361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-137361 dropdown"><a href="#" class="dropdown-toggle" aria-haspopup="true">Previous Years <span class="caret"></span></a><ul role="menu" class="dropdown-menu"><li id="menu-item-171446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-171446 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-israel-2019/">Tel Aviv 2019</a><ul role="menu" class="dropdown-menu"><li id="menu-item-171447" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171447"><a href="http://esctoday.com/participant?contest_year=2019">Participants</a></li></ul></li><li id="menu-item-148277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-148277 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-portugal-2018/">Portugal 2018</a><ul role="menu" class="dropdown-menu"><li id="menu-item-171445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171445"><a href="http://esctoday.com/participant?contest_year=2018">Participants</a></li><li id="menu-item-171444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171444"><a href="http://esctoday.com/eurovision-news-discover-lisbon/">Discover Lisbon</a></li></ul></li><li id="menu-item-137362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-137362 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-ukraine-2017/">Ukraine 2017</a><ul role="menu" class="dropdown-menu"><li id="menu-item-162531" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-162531"><a href="http://esctoday.com/participant?contest_year=2017">Participants</a></li><li id="menu-item-162530" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162530"><a href="http://esctoday.com/eurovision-news-discover-kyiv/">Discover Kyiv</a></li></ul></li><li id="menu-item-104297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-104297 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-sweden-2016/">Sweden 2016</a><ul role="menu" class="dropdown-menu"><li id="menu-item-137583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-137583"><a href="http://esctoday.com/participant?contest_year=2016">Participants</a></li><li id="menu-item-137584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137584"><a href="http://esctoday.com/eurovision-news-discover-stockholm/">Discover Stockholm</a></li></ul></li><li id="menu-item-108242" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-108242 dropdown dropdown-submenu"><a href="http://esctoday.com/eurovision-news/eurovision-news-austria-2015/">Austria 2015</a><ul role="menu" class="dropdown-menu"><li id="menu-item-108246" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-108246 dropdown"><a href="#">Participants</a><ul role="menu" class="dropdown-menu"><li id="menu-item-108245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108245"><a href="http://esctoday.com/participants/eurovision-song-contest-2015-semi-final-1/">Eurovision Song Contest 2015 – Semi-final 1</a></li><li id="menu-item-108244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108244"><a href="http://esctoday.com/participants/eurovision-song-contest-2015-semi-final-2/">Eurovision Song Contest 2015 – Semi-final 2</a></li><li id="menu-item-108243" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108243"><a href="http://esctoday.com/eurovision-song-contest-2015-grand-final/">Eurovision Song Contest 2015 – Grand Final</a></li></ul></li><li id="menu-item-108247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108247"><a href="http://esctoday.com/eurovision-news-discover-vienna/">Discover Vienna</a></li><li id="menu-item-108248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108248"><a href="http://esctoday.com/eurovision-news-specials/eurovision-news-video-message/">Eurostar&#8217;s Video Messages</a></li></ul></li></ul></li><li id="menu-item-142157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142157"><a href="http://esctoday.com/contact/">Contact Us</a></li></ul></div><div class="header-right"><div class="social-icons"></div><a href="#" class="fixed-button navbar-toggle" id="fixed-button"><i></i><i></i><i></i><i></i></a></div><div id="sb-search" class="sb-search"><form action="http://esctoday.com/" method="get"><input class="sb-search-input" placeholder="Enter your search text..." type="text" value="" name="s" id="search"><input class="sb-search-submit" type="submit" value=""><input type="hidden" value="post" name="post_type" id="post_type" /><span class="sb-icon-search fa fa-search" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Search"></span></form></div></nav></div></div></div></div></div></header><div id="content" class="site-content"> <div class="parallax-header"><div class="parallax-wrapper"><div data-bg="url(http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-umk-2020-1280x720.jpg?x80666)" class="parallax-image-holder rocket-lazyload" style=""></div><div class="container"><div class="mag-content parallax-box"><div class="row"><div class="col-md-12 parallax-box"><header class="post-header"><h1 class="post-title">Finland: YLE unveils the UMK 2020 candidates</h1><div class="cat-wrapper"><a href='http://esctoday.com/eurovision-news-countries/eurovision-news-finland/' class='dt_cat bgcolor43'>Finland</a></div><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/sanjay-jiandani/"><b>Sanjay (Sergio) Jiandani</b></a></span> <span class="article-date"><i class="fa fa-clock-o"></i> January 21, 2020 1:30 pm</span><span><i class="fa fa-eye"></i> 21 views</span><a class="comments-count" href="#comments"><span class="fb-comments-count" data-href=""></span></a></p></header></div></div></div></div></div></div>  <div class="container main-wrapper"> <div class="mag-content clearfix"> <div class="row"> <div class="col-md-12"> <div class="content-top-wrapper"><div id="div-gpt-ad-1510691866308-6" class="showDesktop"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-6'); });</script></div></div></div></div></div> <div class="main-content mag-content clearfix"> <div class="row blog-content"> <div class="col-md-8 main-wp dt_content"> <div class="theiaStickySidebar"> <div class="row"><div class="col-md-12"><article id="post-178561" class="dt_post_content clearfix post-178561 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-finland category-eurovision-news tag-eurovision tag-eurovision-2020 tag-umk-2020"><div class="post-content clearfix"><p><strong>Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020 Eurovision Song Contest in Rotterdam.</strong></p><style>.showMobile{display:none}.showDesktop{display:block}@media (max-width:767px){.showMobile{display:block}.showDesktop{display:none}}</style><div id="div-gpt-ad-1510691866308-4" class="showMobile"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-4'); });</script></div><p>The Finns are gearing up for their 2020 national final UMK in full steam. The 2020 Finnish national final is scheduled to be held on <strong>Saturday 7 March</strong>. Finland, Sweden and Denmark will be determining their Eurovision 2020 act and entry on the same night.</p><p>A total of 6 acts will battle for the golden ticket to Rotterdam at UMK 2020. The Finnish national final will be hosted by <strong>Krista Siegfrids</strong> and <strong>Mikko Silvennoinen. </strong>The show will be broadcast live on YLE 1 at <strong>20:00 CET</strong>. The 2020 Finnish Eurovision entry will be determined via a mixed international jury/public voting deliberation.</p><ul><li><strong>Tika</strong> &#8211; <em>I Let My Heart Break</em></li><li><strong>Erika Vikman</strong> &#8211; <em>Cicciolina</em></li><li><strong>Aksel Kankaanranta</strong> &#8211; <em>Looking Back</em></li><li> <strong>F3M</strong> &#8211; <em>Bananas</em></li><li><strong>Sansa</strong> &#8211; <em>Lover Vie</em></li><li><strong> Catharina Zühlke</strong> &#8211; <em>Eternity</em></li></ul><h2>Finland in Eurovision</h2><p>Finland debuted at the Eurovision Song Contest in 1961 and has won the competition once, namely in 2006 when  <strong>Lordi </strong>brought the coveted trophy to home soil for the very first time with<em> Hard Rock Hallelujah</em>. The Nordic country has competed 53 times in Europe’s favourite television show.</p><p>In 2019 the Finns opted for <strong>Darude &amp; Sebastian Rejman</strong> to fly the Finnish flag at the Eurovision Song Contest in Tel Aviv. Hence the broadcaster selected the Finnish hopefuls internally and held a national final with a total of three songs. Darude &amp; Sebastian’s Rejman’s Eurovision entry  <em>Look Away</em> was selected via a 50/50 jury deliberation.</p><p>Despite an extraordinary performance Finland failed to qualify to the Grand Final in Tel Aviv.</p><div class="fve-video-wrapper fve-image-embed fve-thumbnail-image youtube" style="padding-bottom:75%;"> <div class="rll-youtube-player" data-id="VSPhIwOJfRs" data-query="wmode=transparent&amp;modestbranding=1&amp;autohide=1&amp;showinfo=0&amp;rel=0"></div><noscript><iframe src="//www.youtube.com/embed/VSPhIwOJfRs?wmode=transparent&#038;modestbranding=1&#038;autohide=1&#038;showinfo=0&#038;rel=0" width="100%" height="100%" frameborder="0" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe></noscript> </div><p>&nbsp;</p><div id="div-gpt-ad-1510691866308-5" class="showMobile"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-5'); });</script></div><div class="alert alert-success call_to_action joinourteam">ESCToday is growing and always looks for new members to join our team! Feel free to drop us a line if you're interested! Use the <a href="http://esctoday.com/contact/" target="_blank">Contact Us page</a> or send us an email at <a href="mailto:vacancies@esctoday.com">vacancies@esctoday.com</a>!</div></div> <footer class="post-meta"><div class="tags-wrapper"><ul class="tags-widget clearfix"> <li class="trending">Tags:</li><li><a href="http://esctoday.com/tag/eurovision/" rel="tag">eurovision</a></li><li><a href="http://esctoday.com/tag/eurovision-2020/" rel="tag">Eurovision 2020</a></li><li><a href="http://esctoday.com/tag/umk-2020/" rel="tag">UMK 2020</a></li></ul></div><div class="share-wrapper clearfix"><div class="total-shares"> <em id="countUp">0</em> <div class="caption">SHARES</div> </div><div class="share-buttons"><a class="social-share facebook" href="javascript:dt_share('fb', 'Finland: YLE unveils the UMK 2020 candidates', 'Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020 Eurovision Song Contest in Rotterdam....')"> <i class="fa fa-facebook"></i> <span class="alt-text">Share</span> </a><a class="social-share twitter" href="javascript:dt_share('tw', 'Finland: YLE unveils the UMK 2020 candidates', 'Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020 Eurovision Song Contest in Rotterdam....')"> <i class="fa fa-twitter"></i> <span class="alt-text">Tweet</span> </a><a class="social-share google-plus" href="javascript:dt_share('gp', 'Finland: YLE unveils the UMK 2020 candidates', 'Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020 Eurovision Song Contest in Rotterdam....')"> <i class="fa fa-google-plus"></i> <span class="alt-text"></span> </a><a class="social-share linkedin" href="javascript:dt_share('ln', 'Finland: YLE unveils the UMK 2020 candidates', 'Finnish national broadcaster, YLE, has unveiled the names of the six UMK 2020 candidates today, one of them will represent Finland at the forthcoming 2020 Eurovision Song Contest in Rotterdam....')"> <i class="fa fa-linkedin"></i> <span class="alt-text"></span> </a></div></div><div class="author-box clearfix"> <div class="author-avatar"> <a href="http://esctoday.com/author/sanjay-jiandani/"> <img loading="lazy" width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2017/11/wsi-imageoptim-VIENNA-2015-029-150x150.jpg?x80666" /><noscript><img width="150" height="150" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2017/11/wsi-imageoptim-VIENNA-2015-029-150x150.jpg?x80666" class="attachment-thumbnail size-thumbnail" alt="" /></noscript> </a> </div> <div class="author-info"> <h3><a href="http://esctoday.com/author/sanjay-jiandani/">Sanjay (Sergio) Jiandani</a></h3><p class="author-position">Head of International Relations &amp; Communications</p> <p>Sanjay (Sergio) joined esctoday.com in December 2006 as an editor. He was appointed as the Head of Press of ESCToday.com in 2011. Hereafter in 2016 he was promoted as the Head of International Relations &amp; Communications at ESCToday. Sergio has covered the Eurovision Song Contest live 19 times since 2000, having worked for several international magazines and media outlets.</p> <div class="author-contact"> <a href="https://www.facebook.com/jiandani.sergio" target="_blank"><i class="fa fa-facebook fa-lg" title="Facebook"></i></a><a href="https://twitter.com/sergiosanj1" target="_blank"><i class="fa fa-twitter fa-lg" title="Twitter"></i></a><a href="https://es.linkedin.com/in/sanjay-jiandani-570284125" target="_blank"><i class="fa fa-linkedin fa-lg" title="Linkedin"></i></a> </div> </div></div> <h3 class="block-title"><span>Comments:</span></h3><div class="fb-comments" id="comments" data-href="http://esctoday.com/178561/finland-yle-unveils-the-umk-2020-candidates/" data-width="100%" data-numposts="5"></div><div class="row"> <div class="post-nav-wrapper clearfix"> <div class="col-md-6 omega"> <div class="previous-post"> <div class="post-nav-label"> <i class="fa fa-angle-left"></i> Previous post </div> <a href="http://esctoday.com/178544/spain-blas-canto-unveils-the-title-of-his-eurovision-entry/">Spain: Blas Cantó unveils the title of his Eurovision entry!</a> </div> </div> <div class="col-md-6 alpha"> </div> </div></div></footer><div class="related-posts clearfix"><h3 class="block-title"><span>Related posts</span></h3><div class="row "><div class="col-md-12"><article class="simple-post clearfix post-178544 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-eurovision-news-spain tag-blas-canto tag-eurovision tag-eurovision-2020 tag-tve"><div class="simple-thumb"><a href="http://esctoday.com/178544/spain-blas-canto-unveils-the-title-of-his-eurovision-entry/"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-blas-new-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-blas-new-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript></a></div><header><h3 class="h4"><a href="http://esctoday.com/178544/spain-blas-canto-unveils-the-title-of-his-eurovision-entry/">Spain: Blas Cantó unveils the title of his Eurovision entry!</a></h3><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/sanjay-jiandani/">Sanjay (Sergio) Jiandani</a></span> - <span class="article-date"><i class="fa fa-clock-o"></i> January 21, 2020 12:00 pm</span></p></header></article></div></div><div class="row "><div class="col-md-12"><article class="simple-post clearfix post-178531 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-denmark category-eurovision-news tag-denmark-2 tag-dr tag-featured tag-leonora tag-melodi-grand-prix-2020 tag-national-selection tag-p4"><div class="simple-thumb"><a href="http://esctoday.com/178531/denmark-dr-unveils-9-semi-finalists-for-dmgp-2020/"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-DMGP2020-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-DMGP2020-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript></a></div><header><h3 class="h4"><a href="http://esctoday.com/178531/denmark-dr-unveils-9-semi-finalists-for-dmgp-2020/">Denmark: DR unveils 9 semi-finalists for DMGP 2020</a></h3><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/eagadellisyahoo-gr/">Stratos Agadellis</a></span> - <span class="article-date"><i class="fa fa-clock-o"></i> January 20, 2020 9:35 pm</span></p></header></article></div></div><div class="row "><div class="col-md-12"><article class="simple-post clearfix post-178530 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-greece category-eurovision-news tag-eurovision tag-eurovision-2020 tag-greece-2 tag-nicol-raidman tag-sakis-rouvas"><div class="simple-thumb"><a href="http://esctoday.com/178530/greece-sakis-rouvas-releases-duet-version-of-shake-it-with-nicol-raidman/"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-sakis-rouvas-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-sakis-rouvas-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript></a></div><header><h3 class="h4"><a href="http://esctoday.com/178530/greece-sakis-rouvas-releases-duet-version-of-shake-it-with-nicol-raidman/">Greece: Sakis Rouvas releases duet version of &#8216;Shake it&#8217; with Nicol Raidman</a></h3><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/sanjay-jiandani/">Sanjay (Sergio) Jiandani</a></span> - <span class="article-date"><i class="fa fa-clock-o"></i> January 20, 2020 8:00 pm</span></p></header></article></div></div><div class="row "><div class="col-md-12"><article class="simple-post clearfix post-177910 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-ebu category-eurovision-news tag-eurovision-news-ebu tag-eurovision tag-eurovision-2020 tag-featured tag-reference-group"><div class="simple-thumb"><a href="http://esctoday.com/177910/ebu-david-tserunyan-replaces-nicola-caligiore-in-the-reference-group/"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/11/wsi-imageoptim-david-ts-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/11/wsi-imageoptim-david-ts-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript></a></div><header><h3 class="h4"><a href="http://esctoday.com/177910/ebu-david-tserunyan-replaces-nicola-caligiore-in-the-reference-group/">EBU: David Tserunyan replaces Nicola Caligiore in the Reference Group</a></h3><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="http://esctoday.com/author/sanjay-jiandani/">Sanjay (Sergio) Jiandani</a></span> - <span class="article-date"><i class="fa fa-clock-o"></i> January 20, 2020 7:20 pm</span></p></header></article></div></div></div></article></div></div> </div> </div> <div class="col-md-4 dt_sidebar"> <div class="widget-area" role="complementary"> <div class="theiaStickySidebar"> <aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="div-gpt-ad-1510691866308-0" style="margin-bottom:20px"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-0'); });</script></div></div></aside><aside id="social_widget-2" class="widget widget_social_widget"><ul class="social-list"><li class="social-facebook"><a href="http://facebook.com/esctoday" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Facebook"><i class="fa fa-facebook"></i></a></li><li class="social-twitter"><a href="http://twitter.com/esctoday" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Twitter"><i class="fa fa-twitter"></i></a></li><li class="social-youtube"><a href="http://youtube.com/esctodaytv" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Youtube"><i class="fa fa-youtube"></i></a></li><li class="social-linkedin"><a href="https://www.linkedin.com/company/506308" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Linkedin"><i class="fa fa-linkedin"></i></a></li><li class="social-instagram"><a href="https://www.instagram.com/esctoday" data-toggle="tooltip" target="_blank" data-placement="top" title="" data-original-title="Instagram"><i class="fa fa-instagram"></i></a></li></ul></aside><aside id="wysiwyg_widgets_widget-11" class="widget widget_wysiwyg_widgets_widget"><p><a href="http://esctoday.com/eurovision-news-ogae/eurovision-news-ogae-poll-2019/"><img loading="lazy" class="img-responsive aligncenter wp-image-173460 size-large" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20540%20355'%3E%3C/svg%3E" alt="OGAE Poll 2019 - at ESCToday.com" width="540" height="355" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/03/wsi-imageoptim-OGAE-Poll-2019-540x355.jpg" /><noscript><img class="img-responsive aligncenter wp-image-173460 size-large" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/03/wsi-imageoptim-OGAE-Poll-2019-540x355.jpg" alt="OGAE Poll 2019 - at ESCToday.com" width="540" height="355" /></noscript></a></p></aside><aside id="wysiwyg_widgets_widget-12" class="widget widget_wysiwyg_widgets_widget"><p style="text-align: center;"><a href="http://esctoday.com/eurovision-news-infe/eurovision-news-infe-poll-2019/"><img loading="lazy" class="img-responsive aligncenter wp-image-129594 size-full" title="INFE Poll 2019" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="infe_poll_2019" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/04/wsi-imageoptim-INFE-POLL-2019-540x355.jpg" /><noscript><img class="img-responsive aligncenter wp-image-129594 size-full" title="INFE Poll 2019" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/04/wsi-imageoptim-INFE-POLL-2019-540x355.jpg" alt="infe_poll_2019" /></noscript></a></p></aside><aside id="wysiwyg_widgets_widget-5" class="widget widget_wysiwyg_widgets_widget"><p><a href="http://esctoday.com/eurovision-news-opinions/eurovision-news-op_esc/"><img loading="lazy" class="img-responsive aligncenter wp-image-129587 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20480%20260'%3E%3C/svg%3E" alt="OP_ESC" width="480" height="260" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2016/03/op_esc_2016.jpg?x63164" /><noscript><img class="img-responsive aligncenter wp-image-129587 size-full" src="http://esct2019.storage.googleapis.com/wp-content/uploads/2016/03/op_esc_2016.jpg?x63164" alt="OP_ESC" width="480" height="260" /></noscript></a></p></aside><aside id="tabs_widget-5" class="widget widget_tabs_widget"> <ul class="nav nav-tabs" role="tablist" id="widget-tab"> <li role="presentation" class="active"><a href="#dtblock474eb9d06d5312ee055eabf2ee561e99" aria-controls="dtblock474eb9d06d5312ee055eabf2ee561e99" role="tab" data-toggle="tab" aria-expanded="true">Popular</a></li> </ul> <div class="tab-content"> <div role="tabpanel" class="tab-pane animated fadeIn clearfix active" id="dtblock474eb9d06d5312ee055eabf2ee561e99"> <div class=""> <div id="dtblock474eb9d06d5312ee055eabf2ee561e99kkk"><article class="widget-post clearfix post-178485 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-eurovision-news-the-netherlands-2020 tag-eurovision tag-eurovision-2020 tag-npo tag-shula-rijxman"> <div class="simple-thumb"> <a href="http://esctoday.com/178485/eurovision-2020-npo-invites-all-former-dutch-representatives-to-grand-final/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-song-2020-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-song-2020-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178485/eurovision-2020-npo-invites-all-former-dutch-representatives-to-grand-final/">Eurovision 2020: NPO invites all former Dutch representatives to Grand Final</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 1,081 views</p> </header></article><article class="widget-post clearfix post-178473 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-latvia category-eurovision-news tag-eurovision tag-eurovision-2020 tag-latvia-2 tag-ltv-supernova tag-supernova-2020"> <div class="simple-thumb"> <a href="http://esctoday.com/178473/latvia-ltv-unveils-supernova-2020-candidates/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/01/wsi-imageoptim-Supernova2019-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/01/wsi-imageoptim-Supernova2019-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178473/latvia-ltv-unveils-supernova-2020-candidates/">Latvia: LTV unveils Supernova 2020 candidates</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 1,027 views</p> </header></article><article class="widget-post clearfix post-178480 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-eurovision-news-the-netherlands-2020 tag-city-of-rotterdam tag-dave-geensen tag-eurovision tag-eurovision-2020"> <div class="simple-thumb"> <a href="http://esctoday.com/178480/eurovision-2020-rotterdam-will-be-bustling-with-activities-during-the-contest/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-IMG_6043-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-IMG_6043-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178480/eurovision-2020-rotterdam-will-be-bustling-with-activities-during-the-contest/">Eurovision 2020: Rotterdam will be bustling with activities during the contest!</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 1,025 views</p> </header></article><article class="widget-post clearfix post-177910 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-ebu category-eurovision-news tag-eurovision-news-ebu tag-eurovision tag-eurovision-2020 tag-featured tag-reference-group"> <div class="simple-thumb"> <a href="http://esctoday.com/177910/ebu-david-tserunyan-replaces-nicola-caligiore-in-the-reference-group/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/11/wsi-imageoptim-david-ts-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/11/wsi-imageoptim-david-ts-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/177910/ebu-david-tserunyan-replaces-nicola-caligiore-in-the-reference-group/">EBU: David Tserunyan replaces Nicola Caligiore in the Reference Group</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 585 views</p> </header></article><article class="widget-post clearfix post-178544 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-eurovision-news-spain tag-blas-canto tag-eurovision tag-eurovision-2020 tag-tve"> <div class="simple-thumb"> <a href="http://esctoday.com/178544/spain-blas-canto-unveils-the-title-of-his-eurovision-entry/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-blas-new-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-blas-new-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178544/spain-blas-canto-unveils-the-title-of-his-eurovision-entry/">Spain: Blas Cantó unveils the title of his Eurovision entry!</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 250 views</p> </header></article><article class="widget-post clearfix post-178518 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-ebu category-eurovision-news tag-eurovision-news-ebu tag-eurovision tag-eurovision-2020 tag-featured tag-jon-ola-sand tag-martin-osterdahl"> <div class="simple-thumb"> <a href="http://esctoday.com/178518/ebu-martin-osterdahl-appointed-as-esc-executive-supervisor/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-Martin_Osterdahl-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-Martin_Osterdahl-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178518/ebu-martin-osterdahl-appointed-as-esc-executive-supervisor/">EBU: Martin Österdahl appointed as ESC Executive Supervisor</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 408 views</p> </header></article><article class="widget-post clearfix post-178510 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-czech-republic category-eurovision-news tag-ceska-televize tag-eurovision-news-czech-republic tag-eurovision tag-eurovision-2020 tag-featured"> <div class="simple-thumb"> <a href="http://esctoday.com/178510/czech-republic-listen-to-the-national-final-entries-and-start-voting/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-czech-rep-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-czech-rep-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178510/czech-republic-listen-to-the-national-final-entries-and-start-voting/">Czech Republic: Listen to the national final entries and start voting!</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 419 views</p> </header></article><article class="widget-post clearfix post-178449 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-eurovision-news-the-netherlands-2020 tag-eurovision tag-eurovision-2020 tag-npo"> <div class="simple-thumb"> <a href="http://esctoday.com/178449/eurovision-2020-npo-receives-1347-applications-for-esc-postcards/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/12/wsi-imageoptim-postcard-2020-2-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/12/wsi-imageoptim-postcard-2020-2-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178449/eurovision-2020-npo-receives-1347-applications-for-esc-postcards/">Eurovision 2020: NPO receives 1,347 applications for ESC postcards</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 524 views</p> </header></article><article class="widget-post clearfix post-178437 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news-czech-republic category-eurovision-news tag-eurovision tag-eurovision-2020"> <div class="simple-thumb"> <a href="http://esctoday.com/178437/czech-republic-ct-unveils-the-national-final-candidates/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-czech-rep-255x180.jpg?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2020/01/wsi-imageoptim-czech-rep-255x180.jpg?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178437/czech-republic-ct-unveils-the-national-final-candidates/">Czech Republic: CT unveils the national final candidates</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 732 views</p> </header></article><article class="widget-post clearfix post-178391 post type-post status-publish format-standard has-post-thumbnail hentry category-eurovision-news category-eurovision-news-spain tag-blas-canto tag-eurovision tag-eurovision-2020 tag-ot-2020 tag-toni-prieto"> <div class="simple-thumb"> <a href="http://esctoday.com/178391/spain-tve-intends-to-present-blas-cantos-eurovision-entry-in-ot-2020/"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" data-lazy-src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-blas-canto-tve-255x180.png?x80666" /><noscript><img src="http://esct2019.storage.googleapis.com/wp-content/uploads/2019/10/wsi-imageoptim-blas-canto-tve-255x180.png?x80666" class="attachment-simple_big_thumb size-simple_big_thumb wp-post-image" alt="" /></noscript> </a> </div> <header> <h3 class="h5"> <a href="http://esctoday.com/178391/spain-tve-intends-to-present-blas-cantos-eurovision-entry-in-ot-2020/">Spain: TVE intends to present Blas Canto&#8217;s Eurovision entry in OT 2020</a> </h3> <p class="simple-share"><i class="fa fa-eye"></i> 1,338 views</p> </header></article></div> </div> </div> </div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="div-gpt-ad-1510691866308-1" style="margin-top:20px;"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-1'); });</script></div></div></aside> </div></div> </div> </div> </div> <div class="mag-content clearfix"> <div class="row"> <div class="col-md-12"> <div class="content-bottom-wrapper"><div id="div-gpt-ad-1510691866308-3" class="showDesktop"><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1510691866308-3'); });</script></div></div> </div></div></div> </div> </div><footer class="footer source-org vcard copyright clearfix" id="footer"> <div class="footer-main"> <div class="fixed-main"> <div class="container"> <div class="mag-content"> <div class="row"> <div class="col-md-5"> <div id="wysiwyg_widgets_widget-3" class="footer-block clearfix widget_wysiwyg_widgets_widget"><h3 class="footer-title">About us</h3><p><span style="color: #ffffff;">ESCToday was founded in 1999 and since then it delivers Eurovision Song Contest news, polls, interviews, charts and exclusivities on a daily basis.</span></p><p><span style="color: #ffffff;"><a style="color: #ffffff;" href="//esctoday.com/about-us/"><strong>About Esctoday</strong></a></span></p><p><span style="color: #ffffff;"><strong><a style="color: #ffffff;" href="//esctoday.com/about-us/the-team/">The team behind</a></strong></span></p></div> </div> <div class="col-md-3"> <div id="nav_menu-2" class="footer-block clearfix widget_nav_menu"><h3 class="footer-title">Categories</h3><div class="menu-foote_menu-container"><ul id="menu-foote_menu" class="menu"><li id="menu-item-110457" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110457"><a href="http://esctoday.com/eurovision-news/">Eurovision News</a></li><li id="menu-item-110459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110459"><a href="http://esctoday.com/eurovision-news/eurovision-news-past-participants/">Participants News</a></li><li id="menu-item-110456" class="menu-item menu-item-type-post_type_archive menu-item-object-participant menu-item-110456"><a href="http://esctoday.com/participant/">Eurovision Participants</a></li><li id="menu-item-110458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110458"><a href="http://esctoday.com/eurovision-news-ogae/">Fans</a></li></ul></div></div> </div> <div class="col-md-4"> <div id="text-3" class="footer-block clearfix widget_text"><h3 class="footer-title">Social Media</h3><div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/esctoday/" data-tabs="messages, events" data-height="350" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/esctoday/"><a href="https://www.facebook.com/esctoday/">Esctoday</a></blockquote></div></div></div></div> </div> </div> </div> </div> </div> </div> <div class="footer-bottom"> <div class="fixed-main"> <div class="container"> <div class="mag-content"> <div class="row"> <div class="col-md-6"> Copyright ESCToday © 2019. All Rights Reserved </div> <div class="col-md-6"> <div class="social-icons pull-right"> <a href="http://facebook.com/esctoday" title="" data-original-title="Facebook" target="_blank"><i class="fa fa-facebook"></i></a><a href="http://twitter.com/esctoday" title="" data-original-title="Twitter" target="_blank"><i class="fa fa-twitter"></i></a><a href="http://youtube.com/esctodaytv" title="" data-original-title="Youtube" target="_blank"><i class="fa fa-youtube"></i></a><a href="" title="" data-original-title="Google+" target="_blank"><i class="fa fa-google-plus"></i></a><a href="https://www.linkedin.com/company/506308" title="" data-original-title="Linkedin" target="_blank"><i class="fa fa-linkedin"></i></a><a href="https://www.instagram.com/esctoday" title="" data-original-title="Instagram" target="_blank"><i class="fa fa-instagram"></i></a> </div> </div></div> </div> </div> </div> </div> </footer></div><div class="mobile-overlay" id="mobile-overlay"></div><nav id="mobile-nav" class="mm-menu mm-offcanvas"><div><ul id="menu-main-menu-1" class=""><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-38557"><a href="http://esctoday.com/eurovision-news/">News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-38559"><a href="http://esctoday.com/eurovision-news-countries/">All the Countries</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108268"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-albania/">Albania</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108269"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-andorra/">Andorra</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108270"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-armenia/">Armenia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108271"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-australia/">Australia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108272"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-austria/">Austria</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108273"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-azerbaijan/">Azerbaijan</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108274"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-belarus/">Belarus</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108275"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-belgium/">Belgium</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108276"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-bosnia-herzegovina/">Bosnia &#038; Herzegovina</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108277"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-bulgaria/">Bulgaria</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108278"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-croatia/">Croatia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108279"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-cyprus/">Cyprus</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108280"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-czech-republic/">Czech Republic</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108281"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-denmark/">Denmark</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108282"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-estonia/">Estonia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-108283"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-finland/">Finland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108284"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-france/">France</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108286"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-georgia/">Georgia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108287"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-germany/">Germany</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108288"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-greece/">Greece</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108289"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-hungary/">Hungary</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108290"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-iceland/">Iceland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108291"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-ireland/">Ireland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108292"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-israel/">Israel</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108293"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-italy/">Italy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108294"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-latvia/">Latvia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108295"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-lebanon/">Lebanon</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108296"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-liechtenstein/">Liechtenstein</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108297"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-lithuania/">Lithuania</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108298"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-luxembourg/">Luxembourg</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108299"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-malta/">Malta</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108300"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-moldova/">Moldova</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108301"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-monaco/">Monaco</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108302"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-montenegro/">Montenegro</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108303"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-morocco/">Morocco</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108285"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-north-macedonia/">North Macedonia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108304"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-norway/">Norway</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108305"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-poland/">Poland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108306"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-portugal/">Portugal</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108307"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-romania/">Romania</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108308"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-russia/">Russia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108309"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-san-marino/">San Marino</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108310"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-serbia/">Serbia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108311"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-serbia-montenegro/">Serbia &#038; Montenegro</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108312"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-slovakia/">Slovakia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108313"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-slovenia/">Slovenia</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108314"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-spain/">Spain</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108315"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-sweden/">Sweden</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108316"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-switzerland/">Switzerland</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108317"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-the-netherlands/">The Netherlands</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108318"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-turkey/">Turkey</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108319"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-ukraine/">Ukraine</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108320"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-united-kingdom/">United Kingdom</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108321"><a href="http://esctoday.com/eurovision-news-countries/eurovision-news-yugoslavia/">Yugoslavia</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38561"><a href="http://esctoday.com/eurovision-news/eurovision-news-past-participants/">News about Past Participants</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38560"><a href="http://esctoday.com/eurovision-news-ogae/">News from Fan Clubs</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38562"><a href="http://esctoday.com/eurovision-news-archive/">News Archive/History</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-177171"><a href="http://esctoday.com/eurovision-news/eurovision-news-the-netherlands-2020/">Rotterdam 2020</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-177172"><a href="http://esctoday.com/participant?contest_year=2020">Participants</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-137361"><a href="#">Previous Years</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-171446"><a href="http://esctoday.com/eurovision-news/eurovision-news-israel-2019/">Tel Aviv 2019</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171447"><a href="http://esctoday.com/participant?contest_year=2019">Participants</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-148277"><a href="http://esctoday.com/eurovision-news/eurovision-news-portugal-2018/">Portugal 2018</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-171445"><a href="http://esctoday.com/participant?contest_year=2018">Participants</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171444"><a href="http://esctoday.com/eurovision-news-discover-lisbon/">Discover Lisbon</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-137362"><a href="http://esctoday.com/eurovision-news/eurovision-news-ukraine-2017/">Ukraine 2017</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-162531"><a href="http://esctoday.com/participant?contest_year=2017">Participants</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162530"><a href="http://esctoday.com/eurovision-news-discover-kyiv/">Discover Kyiv</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-104297"><a href="http://esctoday.com/eurovision-news/eurovision-news-sweden-2016/">Sweden 2016</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-137583"><a href="http://esctoday.com/participant?contest_year=2016">Participants</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137584"><a href="http://esctoday.com/eurovision-news-discover-stockholm/">Discover Stockholm</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-108242"><a href="http://esctoday.com/eurovision-news/eurovision-news-austria-2015/">Austria 2015</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-108246"><a href="#">Participants</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108245"><a href="http://esctoday.com/participants/eurovision-song-contest-2015-semi-final-1/">Eurovision Song Contest 2015 – Semi-final 1</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108244"><a href="http://esctoday.com/participants/eurovision-song-contest-2015-semi-final-2/">Eurovision Song Contest 2015 – Semi-final 2</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-108243"><a href="http://esctoday.com/eurovision-song-contest-2015-grand-final/">Eurovision Song Contest 2015 – Grand Final</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108247"><a href="http://esctoday.com/eurovision-news-discover-vienna/">Discover Vienna</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108248"><a href="http://esctoday.com/eurovision-news-specials/eurovision-news-video-message/">Eurostar&#8217;s Video Messages</a></li></ul></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142157"><a href="http://esctoday.com/contact/">Contact Us</a></li></ul><div class="mobile-nav-footer"><form role="search" method="get" class="search-form" action="http://esctoday.com/"><div class="input-group"><span class="screen-reader-text">Search for:</span><input type="search" class="form-control" placeholder="Search &hellip;" value="" name="s" /> <span class="input-group-btn"><button type="submit" class="btn btn-default" value="Enter your search text..." ><i class="fa fa-search"></i></button></span></div></form></div></div></nav><script>jQuery(".sb-search").on('click', function(){console.log('clicked');new UISearch(document.getElementById("sb-search"));});</script><script>(function(d, s, id) {var js, fjs = d.getElementsByTagName(s)[0];if (d.getElementById(id)) return;js = d.createElement(s); js.id = id;js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&version=v2.5";
fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));</script><link rel='stylesheet' id='dynamic-css-css' href='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/css/redux-theme.css.gzip?x80666' type='text/css' media='all' /><link rel='stylesheet' id='dt_wp_admin_css-css' href='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/css/custom-meta.css.gzip?x80666' type='text/css' media='all' /><link rel='stylesheet' id='main-style-theme-css' href='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/theme.css.gzip?x80666' type='text/css' media='all' /><script type='text/javascript'>
var wpcf7 = {"apiSettings":{"root":"http:\/\/esctoday.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
</script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-content/plugins/contact-form-7/includes/js/scripts.js.gzip?x80666'></script><script type='text/javascript'>
var viewsCacheL10n = {"admin_ajax_url":"http:\/\/esctoday.com\/wp-admin\/admin-ajax.php","post_id":"178561"};
</script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-content/plugins/wp-postviews/postviews-cache.js.gzip?x80666'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lf0vZAUAAAAALAij3_ilXrgx3ZNj-_aK0RVbmmi'></script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/js/plugins.js.gzip?x80666'></script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/css/plugins/bootstrap/js/bootstrap.min.js.gzip?x80666'></script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-includes/js/wp-embed.min.js.gzip?x80666'></script><script type='text/javascript' src='//cdn.playbuzz.com/widget/feed.js'></script><script type='text/javascript' src='http://esct2019.storage.googleapis.com/wp-content/themes/esctoday/js/admin.js.gzip?x80666'></script><script type="text/javascript">( function( grecaptcha, sitekey, actions ) {var wpcf7recaptcha = {execute: function( action ) {grecaptcha.execute(
sitekey,{ action: action }).then( function( token ) {var forms = document.getElementsByTagName( 'form' );for ( var i = 0; i < forms.length; i++ ) {var fields = forms[ i ].getElementsByTagName( 'input' );for ( var j = 0; j < fields.length; j++ ) {var field = fields[ j ];if ( 'g-recaptcha-response' === field.getAttribute( 'name' ) ) {field.setAttribute( 'value', token );break;}}}} );},executeOnHomepage: function() {wpcf7recaptcha.execute( actions[ 'homepage' ] );},executeOnContactform: function() {wpcf7recaptcha.execute( actions[ 'contactform' ] );},};grecaptcha.ready(
wpcf7recaptcha.executeOnHomepage
);document.addEventListener( 'change',wpcf7recaptcha.executeOnContactform, false
);document.addEventListener( 'wpcf7submit',wpcf7recaptcha.executeOnHomepage, false
);} )(
grecaptcha,'6Lf0vZAUAAAAALAij3_ilXrgx3ZNj-_aK0RVbmmi',{"homepage":"homepage","contactform":"contactform"});</script><div id="cookie-notice" role="banner" class="cn-bottom bootstrap" style="color: #fff; background-color: #000;"><div class="cookie-notice-container"><span id="cn-notice-text">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap button">Ok</a></div></div><script>window.lazyLoadOptions = {elements_selector: "[loading=lazy],.rocket-lazyload",data_src: "lazy-src",data_srcset: "lazy-srcset",data_sizes: "lazy-sizes",class_loading: "lazyloading",class_loaded: "lazyloaded",threshold: 300,callback_loaded: function(element) {if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {if (element.classList.contains("lazyloaded") ) {if (typeof window.jQuery != "undefined") {if (jQuery.fn.fitVids) {jQuery(element).parent().fitVids();}}}}},use_native: true};window.addEventListener('LazyLoad::Initialized', function (e) {var lazyLoadInstance = e.detail.instance;
if (window.MutationObserver) {var observer = new MutationObserver(function(mutations) {var image_count = 0;var iframe_count = 0;var rocketlazy_count = 0;mutations.forEach(function(mutation) {for (i = 0; i < mutation.addedNodes.length; i++) {if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {return;}if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {return;}images = mutation.addedNodes[i].getElementsByTagName('img');is_image = mutation.addedNodes[i].tagName == "IMG";iframes = mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe = mutation.addedNodes[i].tagName == "IFRAME";rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count += images.length;iframe_count += iframes.length;rocketlazy_count += rocket_lazy.length;
if(is_image){image_count += 1;}if(is_iframe){iframe_count += 1;}}} );if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){lazyLoadInstance.update();}} );
var b      = document.getElementsByTagName("body")[0];var config = { childList: true, subtree: true };
observer.observe(b, config);}}, false);</script><script data-no-minify="1" async src="http://esct2019.storage.googleapis.com/wp-content/plugins/rocket-lazy-load/assets/js/12.0/lazyload.min.js.gzip?x80666"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="https://www.youtube.com/embed/ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.id)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script></body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 
Content Delivery Network via S3-compatible: esct2019.storage.googleapis.com

Served from: esctoday.com @ 2020-01-21 13:42:40 by W3 Total Cache
-->